Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Labels:
      None

      Description

      As a client I would like to get the current queue depth on a queue. All existing providers give this information via a custom API or JMX at present.

        Issue Links

          Activity

          fribeiro added a comment -

          Maybe we should revise whether the spec specifies the notifications that must be supported by implementations – this one should definitely be there.

          rdohna added a comment -

          JMS_SPEC-15 is a special case of JMS_SPEC-59

          Nigel Deakin added a comment -

          @fribeiro: I'm not sure what you mean by notifications here and how it relates to obtaining the queue depth (and I don't want to guess). Can you please log your proposal as a new JIRA issue?

          Nigel Deakin added a comment -

          I'm merging this proposal with two more general proposals:

          JMS_SPEC-59 - which covers general non-JMX metadata queries
          JMS_SPEC-18 - which covers general JMX facilities

          I'm going to close this issue as a duplicate of those. Feel free to contribute comments to those issues.


            People

            • Assignee:
              Unassigned
              Reporter:
              colincrist
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: