jms-spec
  1. jms-spec
  2. JMS_SPEC-16

Depth of messages for a durable subscription

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Labels:
      None

      Description

      As a client I would like to get the current approximate number of pending messages for a durable subscription. All existing providers give this information via a custom API or JMX at present.

        Issue Links

          Activity

          fribeiro added a comment -

          My first comment on JMS_SPEC-15 also applies here.

          Nigel Deakin added a comment - - edited

          I'm merging this proposal with two more general proposals:

          JMS_SPEC-59 - which covers general non-JMX metadata queries
          JMS_SPEC-18 - which covers general JMX facilities

          I'm going to close this issue as a duplicate of those. Feel free to contribute comments to those issues.


            People

            • Assignee:
              Unassigned
              Reporter:
              colincrist
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: