jms-spec
  1. jms-spec
  2. JMS_SPEC-23

Allow and specify clustered durable subscribers

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Labels:
      None

      Description

      The current specification arguably disallows clustering durable subscibers by the following wording: "Only one session at a time can have a TopicSubscriber for a particular durable subscription."

      At least one JMS provider (WebSphereMQ) allows multiple TopicSubscribers to the same durable subscription. The subscribers themselves basically act like receivers for a queue.

      This feature helps avoiding a single point of failure.

        Issue Links

          Activity

          Nigel Deakin added a comment - - edited

          Thank you for raising this. This is a good idea which others have proposed as well and is being considered by the expert group for inclusion in the JMS 2.0 early draft. There's a separate (subsequent) JIRA issue which contains the current proposals: JMS_SPEC-40.

          I'm going to close this issue as it is a duplicate of that one. Please feel free to comment on that other issue, which will be updated as it is considered in more detail.


            People

            • Assignee:
              Unassigned
              Reporter:
              F.Degenaar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: