jna
  1. jna
  2. JNA-59

Provide DLL for Windows on AMD64

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: not determined
    • Component/s: native
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      59

      Description

      The win32-x86 DLL currently shipped in the JAR file won't work if running under
      the 64-bit JVM on Windows XP or Vista. An alternative should be included to
      make JNA work on this platform.

        Activity

        twalljava added a comment -

        There is a libffi port to win64 in the python ctypes project which builds with MSVC.

        Ideally the JNA version could be built with mingw, but it's not clear what the
        state of that compiler is on win64 at the moment.

        Andrew Green says he intends to incorporate the ctypes patches into standalone
        libffi, but no timeframe has been announced.

        twalljava added a comment -
            • Issue 80 has been marked as a duplicate of this issue. ***
        twalljava added a comment -
            • Issue 80 has been marked as a duplicate of this issue. ***
        twalljava added a comment -

        mingw is not sufficiently stable as of 20080828, so the build is proceeding with
        the MS compiler.

        win64 branch has been created.

        twalljava added a comment -

        win64 branch merged to head. win64 port is now fully functional.

        dblock added a comment -

        Released, closing.


          People

          • Assignee:
            jna-issues
            Reporter:
            trejkaz
          • Votes:
            6 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: