jogl
  1. jogl
  2. JOGL-21

Cannot build mac OSX version of JoGL with files from the cvs

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: jogl
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Macintosh

    • Issuezilla Id:
      21

      Description

      It looks like the file JAWT_MacOSXDrawingSurfaceInfo from the CVS has not been
      updated. it does not define method cocoaViewRef() and compilation fails on MacOSX:

      ../src/net/java/games/jogl/impl/macosx/MacOSXOnscreenGLContext.java:233: cannot
      resolve symbol
      symbol : method cocoaViewRef ()
      location: class net.java.games.jogl.impl.macosx.JAWT_MacOSXDrawingSurfaceInfo
      nsView = macosxdsi.cocoaViewRef();
      ^
      Note: ../src/net/java/games/jogl/GLCanvas.java uses or overrides a deprecated API.
      Note: Recompile with -deprecation for details.
      1 error
      make[1]: *** [../build/classes/net/java/games/jogl/Animator.class] Error 1
      make: [macosx] Error 2 (ignored)

        Activity

        Hide
        kbr added a comment -

        The Mac OS X port of Jogl requires and will require 10.3, which is currently
        only available as Developer Preview 1. There is no way to make Jogl work with
        10.2 or earlier.

        Show
        kbr added a comment - The Mac OS X port of Jogl requires and will require 10.3, which is currently only available as Developer Preview 1. There is no way to make Jogl work with 10.2 or earlier.

          People

          • Assignee:
            jogl-issues
            Reporter:
            albanc
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: