jogl
  1. jogl
  2. JOGL-334

White textures if disabling mipmap

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: jogl
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: PC

    • Issuezilla Id:
      334

      Description

      The problem is here:

      textureData = TextureIO.newTextureData(iconStream, true, null);

      later the data is set to a texture object. If the mipmap option is set to
      'false' then some images are rendered as white textures.
      The images type is not relevant because, for example, some PNG image are
      rendered right and some don't.
      I attach this URL where I have put a couple of images:
      http://theballoonproject.blogspot.com/2007/11/jogl-mipmap-problem.html

      Thanks.

      1. 400x230-splash-nww.png
        152 kB
      2. georss.png
        64 kB
      3. smipmap_false.jpg
        137 kB
      4. smipmap_true.jpg
        143 kB

        Activity

        asantiago added a comment -

        Created an attachment (id=110)
        Mimmap set to false

        asantiago added a comment -

        Created an attachment (id=111)
        Mipmap set to true

        asantiago added a comment -

        Created an attachment (id=112)
        Problematic image

        asantiago added a comment -

        Created an attachment (id=113)
        No problematic image

        asantiago added a comment -

        Sorry, the JOGL version is "1.1.1-pre-20070918-02:11:29."

        kbr added a comment -

        Need more information. Please attach the output of demos.misc.PrintExt from the
        jogl-demos workspace. Please indicate whether demos.texture.TestTexture shows
        the problem; note that you will need to recompile this demo so that it calls
        TextureIO.newTexture(file, false) instead of TextureIO.newTexture(file, true).
        Note that I can not reproduce this problem on my system, but it probably has
        different non-power-of-two capabilities than yours.

        Also please verify that the texture coordinates you are computing for the mapped
        image are based on Texture.getImageTexCoords() or getSubImageTexCoords(), as
        those are the only guaranteed ways to get the correct texture coordinates for
        the loaded image, especially if non-power-of-two textures are in use (which they
        are here).

        asantiago added a comment -

        Finally I have run the demos.texture.TestTexture and as you point it works fine.
        I tested for JOGL rc7 and for the same version used by WorldWind, both works fine.

        I report it as a problem in the WWJ project, I am not the only one with this
        problem.
        Thanks a lot.

        kbr added a comment -

        Closing as "works for me".


          People

          • Assignee:
            jogl-issues
            Reporter:
            asantiago
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: