Issue Details (XML | Word | Printable)

Key: JOGL-338
Type: Bug Bug
Status: Resolved Resolved
Resolution: Incomplete
Priority: Major Major
Assignee: jogl-issues
Reporter: johan3210
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
jogl

JOGL Applet launched with JNLPAppletLauncher fails on OS X

Created: 17/Jan/08 05:04 AM   Updated: 15/Feb/08 11:27 PM   Resolved: 15/Feb/08 11:27 PM
Component/s: jogl
Affects Version/s: current
Fix Version/s: milestone 1

Time Tracking:
Not Specified

Environment:

Operating System: Mac OS X
Platform: Macintosh
URL: http://www.demicron.com/johan/test.html


Issuezilla Id: 338
Tags:
Participants: jogl-issues, johan3210 and kbr


 Description  « Hide

We are using JNLPAppletLauncher for launching JOGL Applets. It works fine in
Windows, but it doesn't work in Safari on Mac. We have tried on four different
OS X systems and it fails on all of them (Tiger, Leopard, latest Java
version...). We have also tried the first JOGL Example from the Applet Launcher
Project Home page:

<applet code="org.jdesktop.applet.util.JNLPAppletLauncher"
width=600
height=400
archive="
http://download.java.net/media/applet-launcher/applet-launcher.jar,

http://download.java.net/media/jogl/builds/archive/jsr-231-webstart-current/jogl.jar
,
http://download.java.net/media/gluegen/webstart/gluegen-rt.jar,

http://download.java.net/media/jogl/builds/archive/jsr-231-webstart-current/jogl-demos.jar">
<param name="codebase_lookup" value="false">
<param name="subapplet.classname
" value="demos.applets.GearsApplet">
<param name="subapplet.displayname" value="JOGL Gears Applet">
<param name="noddraw.check" value="true">

<param name="progressbar" value="true">
<param name="jnlpNumExtensions" value="1">
<param name="jnlpExtension1"
value="
http://download.java.net/media/jogl/builds/archive/jsr-231-webstart-current/jogl.jnlp">
</applet>

It also fails, with the same error message. The error message generated is the
following:

Mac OS X Version 10.4.11 (Build 8S165)
2008-01-02 07:58:47 -0600
2008-01-02 07:58:47.638 loginwindow[177] FSResolveAliasWithMountFlags returned
err = -35
2008-01-02 07:58:50.662 SystemUIServer[208] lang is:en
(timer):Null value
2008-01-09 07:54:12.264 SoftwareUpdateCheck[1108] Checking for updates
JNLPAppletLauncher: static initializer
os.name = mac os x
nativePrefix = lib nativeSuffix = .jnilib
tmpRootDir = /tmp/jnlp-applet/jln58888
Applet.init
subapplet.classname = com.wirefusion.player.GLAppletPlayer
subapplet.displayname = Untitled_1
Applet.start
Exception in thread "AppletLauncher-Startup" java.lang.NoClassDefFoundError:
IllegalName: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
at java.lang.ClassLoader.preDefineClass (ClassLoader.java:476)
at java.lang.ClassLoader.defineClass(ClassLoader.java:614)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java :163)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:119)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
at
javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java :185)
at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
at
org.jdesktop.applet.util.JNLPAppletLauncher$JNLPParser.<clinit>(JNLPAppletLauncher.java:2180)
at org.jdesktop.applet.util.JNLPAppletLauncher.parseJNLPExtensions
(JNLPAppletLauncher.java:2020)
at
org.jdesktop.applet.util.JNLPAppletLauncher.initResources(JNLPAppletLauncher.java:1329)
at
org.jdesktop.applet.util.JNLPAppletLauncher.initAndStartApplet(JNLPAppletLauncher.java
:1254)
at
org.jdesktop.applet.util.JNLPAppletLauncher.access$000(JNLPAppletLauncher.java:658)
at
org.jdesktop.applet.util.JNLPAppletLauncher$1.run(JNLPAppletLauncher.java:907)

This issue has also been reported on the Applet Launcher project home page, but
I'm not sure if the problem is caused by JOGL or by Applet Launcher.



kbr added a comment - 15/Feb/08 11:27 PM

This was confirmed by the user as a misconfiguration of their web server where
it was not properly returning the 404 status code for missing content, which is
absolutely required for the current applet class loader to work. Closing as Invalid.