jogl
  1. jogl
  2. JOGL-60

Bug fix in tessellation for vertex[Data] callbacks, jogl from Sep 2003

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: jogl
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      60

      Description

      In net.java.games.jogl.impl.tesselator.Render.java:306 in renderLonelyTriangle() of the
      Sept 5 release, the line
       
            tess.callVertexOrVertexData( e.Org.data);
       
      should be
       
            tess.callVertexOrVertexData( e.Org.coords);
       
      The vertex(coords) and vertexData(coords, userData) callbacks were getting the
      userData information in place of the coords.

        Activity

        kbr added a comment -

        Thanks for the patch. This has been fixed in the CVS repository.

        kbr added a comment -

        pepijnve pointed out that the original behavior is by design.

        kbr added a comment -

        pepijnve pointed out that this behavior is by design.


          People

          • Assignee:
            jogl-issues
            Reporter:
            pdjensen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: