The JScience CoordinateConverter interface:
should be a sub-interface of at least the GeoAPI's MathTransform interface, and
maybe a sub-interface of CoordinateOperation as well:
It may be woth to rename the "CoordinateConverter" interface as
"CoordinateTransform" for consistency with the GeoAPI interface names. In
addition, the "convert" method should probably be renamed as "transform" for
consistency as well (note that ISO 19111 make a subtle nuance between
"conversion" and "transformation").