Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      52

      Description

      I'm using the Glassfish v2 b32, and latest nightly webpack (jan 24).

      The sample can be built and deployed properly.
      However, when I try and access the
      "Ajax Scrollable Result Set with per-cell editing using jMaki." (linked
      to:http://localhost:8080/jsf-jmaki/home.jsf)
      I get the following error:
      org.apache.jasper.JasperException: /mainColumn.jsp(2,58) PWC6188: The absolute
      uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml or the
      jar files deployed with this application

      Similarly, when I try and access the link: "Ajax FishEye widget with JSF
      ValueChangeListener" (linked to: http://localhost:8080/jsf-jmaki/fisheye.jsf) ,
      I get the following error:
      org.apache.jasper.JasperException: /mainColumnFishEye.jsp(4,58) PWC6188: The
      absolute uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml
      or the jar files deployed with this application

      ------------Here's the server side stack trace: ----------------
      [#|2007-01-24T12:16:13.609-0500|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=18;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=b02c14b2-25db-4dc9-bfc8-fbaa9e0c6314;|ApplicationDispatcher[/jsf-jmaki]
      PWC1231: Servlet.service() for servlet jsp threw exception

      org.apache.jasper.JasperException: /mainColumnFishEye.jsp(4,58) PWC6188: The
      absolute uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml
      or the jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      #]

      [#|2007-01-24T12:16:13.609-0500|WARNING|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.lifecycle|_ThreadID=18;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=b02c14b2-25db-4dc9-bfc8-fbaa9e0c6314;|executePhase(RENDER_RESPONSE
      6,com.sun.faces.context.FacesContextImpl@d41df8) threw exception

      javax.faces.FacesException: org.apache.jasper.JasperException:
      /fisheye.jsp(66,0) /mainColumnFishEye.jsp(4,58) PWC6188: The absolute uri:
      http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml or the jar
      files deployed with this application

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:427)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      Caused by: org.apache.jasper.JasperException: /fisheye.jsp(66,0)
      /mainColumnFishEye.jsp(4,58) PWC6188: The absolute uri:
      http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml or the jar
      files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:49)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:344)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:111)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:365)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      ... 30 more

      Caused by: org.apache.jasper.JasperException: /mainColumnFishEye.jsp(4,58)
      PWC6188: The absolute uri: http://java.sun.com/jmaki-jsf cannot be resolved in
      either web.xml or the jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      ... 54 more

      #]

      [#|2007-01-24T12:16:13.625-0500|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=18;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=b02c14b2-25db-4dc9-bfc8-fbaa9e0c6314;|StandardWrapperValve[Faces
      Servlet]: PWC1406: Servlet.service() for servlet Faces Servlet threw exception

      org.apache.jasper.JasperException: /mainColumnFishEye.jsp(4,58) PWC6188: The
      absolute uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml
      or the jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      #]

      [#|2007-01-24T12:18:53.843-0500|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-1;_RequestID=81178b09-2219-4adb-993f-6180fba62a2c;|ApplicationDispatcher[/jsf-jmaki]
      PWC1231: Servlet.service() for servlet jsp threw exception

      org.apache.jasper.JasperException: /mainColumn.jsp(2,58) PWC6188: The absolute
      uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml or the
      jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:323)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      #]

      [#|2007-01-24T12:18:53.843-0500|WARNING|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.lifecycle|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-1;_RequestID=81178b09-2219-4adb-993f-6180fba62a2c;|executePhase(RENDER_RESPONSE
      6,com.sun.faces.context.FacesContextImpl@1536f50) threw exception

      javax.faces.FacesException: org.apache.jasper.JasperException: /home.jsp(66,0)
      /mainColumn.jsp(2,58) PWC6188: The absolute uri: http://java.sun.com/jmaki-jsf
      cannot be resolved in either web.xml or the jar files deployed with this application

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:427)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:323)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      Caused by: org.apache.jasper.JasperException: /home.jsp(66,0)
      /mainColumn.jsp(2,58) PWC6188: The absolute uri: http://java.sun.com/jmaki-jsf
      cannot be resolved in either web.xml or the jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:49)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:344)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:111)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:365)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      ... 31 more

      Caused by: org.apache.jasper.JasperException: /mainColumn.jsp(2,58) PWC6188: The
      absolute uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml
      or the jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      ... 55 more

      #]

      [#|2007-01-24T12:18:53.843-0500|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-1;_RequestID=81178b09-2219-4adb-993f-6180fba62a2c;|StandardWrapperValve[Faces
      Servlet]: PWC1406: Servlet.service() for servlet Faces Servlet threw exception

      org.apache.jasper.JasperException: /mainColumn.jsp(2,58) PWC6188: The absolute
      uri: http://java.sun.com/jmaki-jsf cannot be resolved in either web.xml or the
      jar files deployed with this application

      at
      org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:60)

      at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:346)

      at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:140)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:404)

      at
      org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:209)

      at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:469)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:549)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:127)

      at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:361)

      at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:398)

      at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:541)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1613)

      at org.apache.jasper.compiler.Parser.parseBody(Parser.java:1867)

      at org.apache.jasper.compiler.Parser.parseOptionalBody(Parser.java:1126)

      at org.apache.jasper.compiler.Parser.parseCustomTag(Parser.java:1437)

      at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1636)

      at org.apache.jasper.compiler.Parser.parse(Parser.java:152)

      at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:210)

      at org.apache.jasper.compiler.ParserController.parse(ParserController.java:111)

      at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:158)

      at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)

      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:571)

      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:344)

      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:464)

      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:358)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:839)

      at
      org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)

      at
      org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:528)

      at
      org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:461)

      at
      org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:353)

      at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:422)

      at
      com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:447)

      at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:116)

      at
      com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.render(PartialTraversalLifecycle.java:92)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:207)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:249)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:323)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:93)

      #]

        Activity

        Ed Burns added a comment -

        I just tested this standalone this morning. I'll investigate with your parameters.

        Ed Burns added a comment -

        I am happy to report that I just installed Glassfish v2 b32 on a Solaris 10 x86 machine. I then installed
        the latest nightly target_r1 build. I then cd'd to the top level directory and did rm -rf jsf-extensions. I
        then went into SUNWappserver/lib/addons and did rm -f jsf-extension*.jar.

        I then unpacked a standalone build of jsf-extensions into the top level target_r1/jsf-extensions
        directory.

        I then did asant inside the samples directory therein. The samples built successfully.

        I then copied all jsf-extensions*.jar files into SUNWappserver/lib/addons.

        I then started the server and visited the jmaki app. It worked completely fine.

        Therefore, I'm marking WORKSFORME.


          People

          • Assignee:
            jsf-extensions-issues
            Reporter:
            aditya_dada
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: