Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Incomplete
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: runtime
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      83

      Description

      A couple Woodstock users are reporting issues with JSF Extensions and facelets.
      It's not clear if the underlying issue is due to JSF Extensions or not, but the
      com_sun_faces_ajax.js is generating the error below. This error is in regard to
      the auto-validate feature of the Woodstock TextField, which uses JSF Extensions
      to validate asynchronously. In this scenario, an id and valid property is
      returned to indicate the success of the JSF validator.

      "Mozilla error console reports:

      Error: no element found
      Source File:
      http://localhost:8080/gesif/clientes/entrada/plantillas/alta.jsf
      Line: 1, Column: 158
      Source Code:
      <partial-response><components><render
      id="plantillas:clienteid"><markup><![CDATA[

      {"id":"plantillas:clienteid","valid":true}

      ]]></markup></render></components>-------------------------------------------------------------------------------------------------------------------------------------------------------------^

      (There is a component named 'plantillas:clienteid' )

      And

      Error: I has no properties
      Source File:
      http://localhost:8080/gesif/theme/META-INF/com_sun_faces_ajax.js
      Line: 1"

        Activity

        danl added a comment -

        Created an attachment (id=21)
        E-mail discussion

        danl added a comment -

        Added e-mail discussion. (Please ignore the Dojo comments.) As a workaround, one
        user apparently replaced their validatorExpression with <f:validator>. Another
        user simply dropped using facelets all together and switched to JSPs.

        danl added a comment -

        We just received an update from the user who reported the issue. It turns out
        not to be a bug at all, but a simple user error. I was finally able to reproduce
        the problem myself after removing the JSF Extensions ViewHandler from my web.xml
        file.

        Steven Bell wrote:
        > I have found the enemy, and it is me!
        >
        > So after moving to jsp pages I was getting the server side validation
        executing, but my client side updates were still not working.
        >
        > I was starting to build a new clean web project in order to flesh out the
        problem when I noticed a few lines in the woodstock example apps web.xml that I
        didn't have.
        >
        > I had:
        >
        > <servlet>
        > <servlet-name>faces</servlet-name>
        > <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
        > <load-on-startup>1</load-on-startup>
        > </servlet>
        >
        > In the woodstock example it was:
        >
        > <servlet>
        > <servlet-name>faces</servlet-name>
        > <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
        > <init-param>
        > <param-name>javax.faces.LIFECYCLE_ID</param-name>
        > <param-value>com.sun.faces.lifecycle.PARTIAL</param-value>
        > </init-param>
        > <load-on-startup>1</load-on-startup>
        > </servlet>
        >
        > So after a week of digging around it looks like the problem was right in front
        of my face. I'm not sure if there is still a problem with facelets regarding
        the issues I was having with action vs. actionExpression and getting the
        validators to work (as per my first message on this thread), but at least I can
        move forward now.
        >
        > By the way the "I has no properties" error went away when I added the
        LIFECYCLE_ID to the servlet.

        LittleBunny added a comment -

        I have been facing the issue , I am using Netbeans 6.7 and trying to use Ajax with it.I have installed JSF Extension (Ajax),dynamicFaces Library,set Parameters in web.xml but my Ajax Transaction is not performed.I have to call a js on a button click using Ajax but it is not working.It is working very fine in netbeans 6.1.Please Tell me if I am missing something or is there anything additional i have to do with netbeans 6.7 to make Ajax perform Transaction?

        Ed Burns added a comment -

        Unfortunately, there are no plans for continuing development on the jsf-extensions project.


          People

          • Assignee:
            jsf-extensions-issues
            Reporter:
            danl
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: