jsip
  1. jsip
  2. JSIP-460

Cannot add multiple reason headers

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      See https://code.google.com/p/sipservlets/issues/detail?id=216

      1.Call addHeader to add a Reason header for SIP
      2.Call addHeader to add a Reason header for Q.850
      3.Send the message

      What is the expected output? What do you see instead?
      I expect to see a message being sent with both reason headers (as per RFC 3326). Only the first header is present in the outgoing message.

      Please provide any additional information below.

      The problem is in gov.nist.javax.sip.message.ListMap - it does not include ReasonList in the table of headers that may contain more than one item (headerListTable). When addHeader is called in gov.nist.javax.sip.message.SIPMessage, it calls attachHeader which asks ListMap if the Reason header may be a list. ListMap returns no and step 2 above silently drops the second header. As the header is not added to the message, the header is not included when the message is sent.

        Activity

        deruelle_jean added a comment -

        Fixed in r2305 + non regression test

        mranga added a comment -

        Bah! there is no Reason for multiple Reason headers. Reason headers are meant for lodging complaints. They should be banned.

        OK just kidding.

        deruelle_jean added a comment -

        We should file Reason Header complaints against the Reason Header RFC and go in an endless Reason loop


          People

          • Assignee:
            Unassigned
            Reporter:
            deruelle_jean
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: