Affects Version/s: None
Fix Version/s: 1.0-pfd
The idea here is to make the following two changes, which work well together:
1. Remove 'value' from most getter names
2. Use the same method naming convention on JsonNumber as is used on java.lang.Number
The result is that repetitive-looking use cases like jsonObject.getNumberValue("num").getDoubleValue() turn into this non-repetitive arrangement: jsonObject.getNumber("num").doubleValue().
This suggestion, along with
JSON_PROCESSING_SPEC-53, has been implemented here: