Currently the HttpMethod annotation is applied only to other annotations. So now
there are @HEAD and @GET type annotations. This gets a bit confusing since it
allows someone to put a @HEAD and @GET annotation both on the same method. It
seems it would make much more sense to just have the HttpMethod annotation's
value be an HttpMethodType enumeration. Then you can only have one HttpMethod
per method. Simple, concise, and a lot easier to understand and code to.