jsr348
  1. jsr348
  2. JSR348-70

Simplify Maintenance Review process by eliminating Item Exception Ballot and Change Log

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None

      Description

      Here's a proposed change that simplifies the Maintenance Review process by
      eliminating the Item Exception Ballot and the Change Log. The Change Log is
      replaced by the issue tracker, plus a general reference to the materials
      submitted to the PMO for the Maintenance Review. (References to the Change
      Log elsewhere need to be fixed as well.)

      4.1 MAINTENANCE REVIEW

      The ML will document all proposed Specification changes as separate
      line item changes (indicating dependencies between items) and then send
      a request to the PMO to initiate a Maintenance Review. Before the
      Maintenance Review begins, the ML must summarize comments received
      through the Maintenance feedback email list and must indicate the
      disposition of each comment (e.g. deferred with a brief explanation,
      rejected with a brief explanation, included in the proposal.) This
      summary may be in the form of references to an issue tracking system.
      This summary will be posted along with the MR request on the JSR Page.
      The PMO will then make a public announcement and begin the review.

      The ML may choose to modify one or more of the proposed changes based
      on comments received during the review.

      At the close of the Maintenance Review the PMO will initiate a 7-day
      Maintenance Review Ballot. During this ballot EC members should vote
      "yes" if they agree that the Maintenance Release should go ahead as the
      Spec Lead has proposed, and "no" if they believe that one or more of
      the changes proposed by the ML is inappropriate for a Maintenance
      Release and should be deferred to a follow-on JSR. "No" votes must be
      accompanied by comments in which the offending items are identified and
      the reasons for the objection are explained.

      If any line item receives "no" votes from 1/3 or more of the EC members,
      the ML may choose to complete the MR without those items, or may choose
      to withdraw the MR, possibly resubmitting a modified version or possibly
      submitting a full JSR.

      NOTE: there is no minimum number of "yes" votes required to move
      forward with the proposed Maintenance Release, and "no" votes cannot
      prevent a release unless the ML is unwilling to defer items.

      At the end of Maintenance Review the ML will update the Specification,
      incorporating all approved changes. Items that received "no" votes
      from 1/3 or more of the EC members must not be included.

      4.2 MAINTENANCE RELEASE

      At any time after a Maintenance Review Ballot the Spec Lead will update
      the Specification, RI, and TCK, as necessary and submit them to the PMO
      for publication in a Maintenance Release. The PMO verifies that the
      necessary changes have been made, and publishes the Specification, and
      pointers to the RI and TCK on the JSR Web Page.

      NOTE: until the Maintenance Release stage is reached any proposed
      changes should be considered preliminary and subject to change, and
      therefore should not be implemented in shipping products.

        Issue Links

          Activity

          pcurran added a comment -

          Force assignment to Eduardo by closing and reopening...

          eduardo added a comment -

          I've incorporated all suggested changes. I've also noticed that the changes include both "Issue List" and "Issue list". These should be normalized and "Issue List" should be either defined or left as "issue list". I will open an issue on this.

          pcurran added a comment -

          Reopening until we've confirmed that the changes implement what we agreed.

          pcurran added a comment -

          It is resolved - we just need to review

          pcurran added a comment -

          Closed, as agreed at the September 21 Working Group meeting.


            People

            • Assignee:
              eduardo
              Reporter:
              Bill Shannon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: