jsr-283
  1. jsr-283
  2. JSR_283-333

Better name for jcr:setAccessControlPolicy and jcr:getAccessControlPolicy privileges

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: access control
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      333

      Description

      according to the specification the jcr:setAccessControlPolicy and
      jcr:getAccessControlPolicy privileges are also used to grant permission for

      AccessControlManager.addAccessControlEntry(String, Principal, Privilege[])
      AccessControlManager.removeAccessControlEntry(String, AccessControlEntry)

      and

      AccessControlManager.getAccessContolEntries(String)

      respectively.
      However, the description of the privileges states, that they are used to get and
      modify the AccessControlPolicies.

      To me it makes sense to use them for both AccessControlPolicy and -Entry related
      methods, but i would in this case rename them to something more general.

      angela

        Issue Links

          Activity

          Hide
          anchela added a comment -

          suggestion for the renaming:

          jcr:readAccessControl
          jcr:modifyAccessControl

          Show
          anchela added a comment - suggestion for the renaming: jcr:readAccessControl jcr:modifyAccessControl
          Hide
          stefan_guggisberg added a comment -

          resolved as fixed as per F2F decision in Basel, Sept 07:

          consensus,, javax.jcr.....readAccessControl

          Show
          stefan_guggisberg added a comment - resolved as fixed as per F2F decision in Basel, Sept 07: consensus,, javax.jcr.....readAccessControl
          Hide
          stefan_guggisberg added a comment -

          -> javax.jcr....ReadAccessControl

          Show
          stefan_guggisberg added a comment - -> javax.jcr....ReadAccessControl
          Hide
          anchela added a comment -

          specification/api need to be adjusted

          Show
          anchela added a comment - specification/api need to be adjusted
          Hide
          anchela added a comment -

          if i remember correctly we also decided to rename

          'jcr:setProperties'

          to modifyProperties (javax.jcr.security.Privilege.SetProperties)

          Show
          anchela added a comment - if i remember correctly we also decided to rename 'jcr:setProperties' to modifyProperties (javax.jcr.security.Privilege.SetProperties)
          Hide
          anchela added a comment -

          if i remember correctly we also decided to rename

          'jcr:setProperties'

          to modifyProperties (javax.jcr.security.Privilege.ModifyProperties)

          Show
          anchela added a comment - if i remember correctly we also decided to rename 'jcr:setProperties' to modifyProperties (javax.jcr.security.Privilege.ModifyProperties)
          Hide
          Peeter Piegaze added a comment -

          fixed

          Show
          Peeter Piegaze added a comment - fixed
          Hide
          anchela added a comment -

          .

          Show
          anchela added a comment - .

            People

            • Assignee:
              jsr-283-issues
              Reporter:
              anchela
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: