jsr-283
  1. jsr-283
  2. JSR_283-354

Clarify null handling in QueryObjectModelFactory

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: javadoc/api
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      354

      Description

      Most of the parameters passed to methods of QueryObjectModelFactory are
      specified as non-null, however it does not say what an implementation should do
      if null is passed. Should an implementation throw a NullPointerException,
      InvalidQueryException or RepositoryException?

        Issue Links

          Activity

          stefan_guggisberg added a comment -

          resolved as fixed as per F2F decision in Basel, Sept 07:

          blanket statement on null ponter

          Peeter Piegaze added a comment -

          consensus reached but not yet fixed in spec

          Peeter Piegaze added a comment -

          Decision of of Basel F2F Sept 07 was:

          Blanket statement for the specification that all parameters are non-null unless otherwise stated. If null is
          passed the result is unspecified

          Peeter Piegaze added a comment -

          Will fix in spec after re-org as per Costa Mesa F2F. At that point we can find a suitable place for this
          statement.

          Peeter Piegaze added a comment -

          Status changed to STARTED

          Peeter Piegaze added a comment -

          Fixed

          Peeter Piegaze added a comment -

          To be more specific, as decided at the Costa Mesa F2F I have added the following gloabl statement to the
          preface of the spec:

          1.5 Null Parameters
          When describing JCR API methods, this specification and the Javadoc assume that all parameters passed
          are non-null, unless otherwise stated. If null is passed as parameter and its behavior is not explicitly
          described in this specification or in the Javadoc, then the behavior of the method in that case is
          implementation-specific.

          Peeter Piegaze added a comment -
              • Issue 537 has been marked as a duplicate of this issue. ***

            People

            • Assignee:
              jsr-283-issues
              Reporter:
              mreutegg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: