Currently Privilege names are package-style names (e.g.
javax.jcr.security.Privilege.READ). For consistency with what "name" means
elsewhere, it would be better for them to be JCR names. Since the name of a
privilege is only to identify the Privilege object, this change should incur
minimal burden on implementors.