jsr-333
  1. jsr-333
  2. JSR_333-24

Review System Requirements in Spec Document

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: None
    • Component/s: spec
    • Labels:
      None

      Description

      While not a bug as such, I was wondering when going through the Word file jcr-spec.doc if

      >1.4 System Requirements
      >The JCR 2.1 requires Java Runtime Environment (JRE) 1.4 or greater.

      was simply a Copy&Paste case from previous versions, or if the foundation was really still Java 1.4 with no feature of Java 5 being used or considered?

        Activity

        Hide
        thomasmueller2 added a comment -

        I'm not sure if its necessary to change this statement, because Java 1.4 applications can still be supported even if the API uses Java 5 features such as generics. JSR_333-18 uses generics, but the API in theory is still compatible with Java 1.4.

        But probably it's simpler to require Java 5, because that would simplify testing.

        Show
        thomasmueller2 added a comment - I'm not sure if its necessary to change this statement, because Java 1.4 applications can still be supported even if the API uses Java 5 features such as generics. JSR_333-18 uses generics, but the API in theory is still compatible with Java 1.4. But probably it's simpler to require Java 5, because that would simplify testing.
        Hide
        Peeter Piegaze added a comment -

        Proposal:

        Change

        >1.4 System Requirements
        >The JCR 2.1 requires Java Runtime Environment (JRE) 1.4 or greater.

        to

        >1.4 System Requirements
        >The JCR 2.1 requires Java Runtime Environment (JRE) 5.0 or greater.

        Can we agree to this change?

        Show
        Peeter Piegaze added a comment - Proposal: Change >1.4 System Requirements >The JCR 2.1 requires Java Runtime Environment (JRE) 1.4 or greater. to >1.4 System Requirements >The JCR 2.1 requires Java Runtime Environment (JRE) 5.0 or greater. Can we agree to this change?
        Hide
        thomasmueller2 added a comment -

        +1 for "requires Java Runtime Environment (JRE) 5.0 or greater."

        Show
        thomasmueller2 added a comment - +1 for "requires Java Runtime Environment (JRE) 5.0 or greater."
        Hide
        Peeter Piegaze added a comment -

        Fixed as suggested.

        Show
        Peeter Piegaze added a comment - Fixed as suggested.

          People

          • Assignee:
            Unassigned
            Reporter:
            cat
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: