lg3d-core
  1. lg3d-core
  2. LG3D_CORE-467

Regression in src/devscripts/setup script

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: Runtime scripts
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      467

      Description

      The following two problems have been introduced in the src/devscripts/setup script:

      1. The debug TCP/IP port address was changed from "8888" to "88888", which is
      out of range, preventing debugging via a JPDA debugger such as NetBeans.

      2. The setup script overwrites CLASSPATH rather than prepending the necessary
      jar files, which makes debugging using a development version of Java 3D difficult.

      Following are the diffs for the suggested fix.

      ===================================================================
      RCS file: /cvs/lg3d-core/src/devscripts/setup,v
      retrieving revision 1.32
      diff -w -u -r1.32 setup
      — setup 24 Feb 2006 22:13:15 -0000 1.32
      +++ setup 9 Mar 2006 01:13:31 -0000
      @@ -10,7 +10,7 @@

      if [ $

      {RELEASE:-0}

      == 0 ]; then
      DEBUG="1"

      • export DEBUG_FLAGS="-Xdebug
        -Xrunjdwp:transport=dt_socket,server=y,address=88888,suspend=n -ea"
        + export DEBUG_FLAGS="-Xdebug
        -Xrunjdwp:transport=dt_socket,server=y,address=8888,suspend=n -ea"
        fi

      LOGFILE="/var/tmp/lgserver.log"
      @@ -143,10 +143,10 @@
      fi

      if [ "$

      {RELEASE:-0}

      " == "0" ]; then

      • export CLASSPATH="$ {BUILDPLATFORM}/lib/lg3d-bootstrap.jar"
        + export CLASSPATH="${BUILDPLATFORM}

        /lib/lg3d-bootstrap.jar:$

        {CLASSPATH}"
        export BOOTCLASSPATH="${BUILDPLATFORM}/lib/lg3d-awt-toolkit.jar"
        else
        - export CLASSPATH="${LGDIR}/lib/lg3d-bootstrap.jar"
        + export CLASSPATH="${LGDIR}/lib/lg3d-bootstrap.jar:${CLASSPATH}

        "
        export BOOTCLASSPATH="$

        {LGDIR}

        /lib/lg3d-awt-toolkit.jar"
        fi

        Activity

        gameldar added a comment -

        >1. The debug TCP/IP port address was changed from "8888" to "88888", which is
        >out of range, preventing debugging via a JPDA debugger such as NetBeans.

        Ack that shouldn't be there - that is a carry over from one of my commits - port
        8888 is used on Debian systems so I had changed it to get it working.

        >2. The setup script overwrites CLASSPATH rather than prepending the necessary
        >jar files, which makes debugging using a development version of Java 3D difficult.

        Do you need the debug classes loaded by the boot classloader? If so changing the
        CLASSPATH here is fine - otherwise the classpath is set in
        [src/]etc/lg3d/classpath/*

        Refer to http://forums.java.net/jive/thread.jspa?threadID=13012&tstart=15
        for more details about this.

        paulby added a comment -

        Kirk can you check the IANA list to see if there is a 'debug type' port already
        reserved. Hopefully this will reduce the risk of conflicts.

        If there is nothing there then we will just have to pick another random port.

        gameldar added a comment -

        Port 8888 is allocated to NewsEDGE server TCP (TCP 1) which I'm sure I didn't
        have installed but I can't see what was using it (it is possible that it was a
        setup of Tomcat on my old machine - but I remember having the problem on gentoo
        as well). However there isn't a java remote debug port registered - in terms of
        debugging there is only the ones specific for gdb (2159), but nothing java or
        netbeans specific.

        That said I would steer away from 8888 because it may be used by Tomcat, or is
        at least a small change away from port 8080. If we wanted to stay around that
        number space 8881-8887 are currently unassigned. I think it would be worth Sun
        choosing and reserving the port number for remote java debugging.

        Kirk

        hideya added a comment -

        Set the Target milestone to 0.8.0

        paulby added a comment -

        Fixed, default port is now 8889


          People

          • Assignee:
            paulby
            Reporter:
            kcr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: