Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      ComboBox Popup width is smaller than item width so item is not completely shown.

      ComboBox cb = new ComboBox();
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("14654665546");
      cb.addItem("1765765");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("16545645");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("14654665546");
      cb.addItem("1765765");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("1");
      cb.addItem("16545645");
      cb.addItem("1");

      Form f = new Form();
      f.setLayout(new TableLayout());

      f.addComponent(cb);

        Activity

        vprise added a comment -

        LWUIT is optimized to only check the first 5 rows for size since a list can be infinite.
        You can use either setRenderingPrototype() or setListSizeCalculationSampleCount() to let the list/combobox determine a more appropriate width.


          People

          • Assignee:
            Unassigned
            Reporter:
            almasproject
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: