Issue Details (XML | Word | Printable)

Key: LWUIT-489
Type: New Feature New Feature
Status: Resolved Resolved
Resolution: Invalid
Priority: Major Major
Assignee: Unassigned
Reporter: tempusername
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
lwuit

Ability to export all images from res file

Created: 20/Nov/11 02:42 PM   Updated: 14/Dec/11 05:55 AM   Resolved: 20/Nov/11 07:00 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Time Tracking:
Original Estimate: 1 day
Original Estimate - 1 day
Remaining Estimate: 1 day
Remaining Estimate - 1 day
Time Spent: Not Specified
Time Spent - Not Specified

Tags: res editor export
Participants: tempusername and vprise


 Description  « Hide

I'de like to request a feature to enable to export all images from res file to a specific directory.
the files names should as their lwuit-image names (and not original files name incase they were saved).

I often find myself in need of the images i previously imported into a res file either because i lost the originals or need to compare something or need to run an external tool on them etc.

(obviously to prevent malicious use if the res is password protected it should request the password because exporting the graphics)



vprise added a comment - 20/Nov/11 07:00 PM

The export feature in the file menu already does that.


tempusername added a comment - 30/Nov/11 08:11 PM

oops i dont know how i missed that... however the image files dont get export nicely with different file names so is it possible to add support for running pngout in adition to optipng (since pngout gives the best results of all) (but also add line paramters for it execution)


vprise added a comment - 11/Dec/11 06:31 AM

I looked at pngout and the main issue I could only find it for Windows and right now I use a Mac so it would be a hassle for me to implement it. The file names are based on the name of the entry, the problem is that I don't quite know the right extension to give during export (a file might be a gif, tif, png, jpg etc.) I can write code to detect that and try to be "clever" about this during export but it isn't a trivial task since then every image needs to be linked to the new "fake" name.
When adding images using the add multiple images functionality the image defaults to having the file name as its name thus the name within the resource file includes the extension. Export then works in a better way. The problem is that this doesn't apply to image borders, I can theoretically generate image border names with extension which is actually a good idea.


tempusername added a comment - 11/Dec/11 02:37 PM

pngout does have a mac port (according to its page http://advsys.net/ken/utils.htm)
in regards to the image names its not only a problem of image borders... multi-res images also suffer from a naming problem in export because they get suffix with their res size description (after their name even if it was .png)


vprise added a comment - 14/Dec/11 05:55 AM

I'll take a look at the pngout link, it will take me some time though since I'm in the middle of quite a bit of things I need to complete.
You are right about the multi-image, I'll add that it always exports with a .png suffix which should work for 98% of the cases.