Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Mark the plugin as thredsafe or not.
      See http://maven.apache.org/developers/mojo-api-specification.html
      https://cwiki.apache.org/MAVEN/parallel-builds-in-maven-3.html

      The we can avoid these FUD messages

      18:17:05  [WARNING] *****************************************************************
      18:17:05  [WARNING] * Your build is requesting parallel execution, but project      *
      18:17:05  [WARNING] * contains the following plugin(s) that are not marked as       *
      18:17:05  [WARNING] * @threadSafe to support parallel building.                     *
      18:17:05  [WARNING] * While this /may/ work fine, please look for plugin updates    *
      18:17:05  [WARNING] * and/or request plugins be made thread-safe.                   *
      18:17:05  [WARNING] * If reporting an issue, report it against the plugin in        *
      18:17:05  [WARNING] * question, not against maven-core                              *
      18:17:05  [WARNING] *****************************************************************
      18:17:05  [WARNING] The following plugins are not marked @threadSafe in pays-core-integration:
      18:17:05  [WARNING] org.codehaus.mojo:axistools-maven-plugin:1.4
      18:17:05  [WARNING] org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.8.0
      18:17:05  [WARNING] *****************************************************************
      

        Issue Links

          Activity

          lexi added a comment -

          Duplicate of MAVEN_JAXB2_PLUGIN-45.


            People

            • Assignee:
              lexi
              Reporter:
              davidkarlsen2
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Remaining Estimate - 1 hour
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified