metro
  1. metro
  2. METRO-14

War works on Tomcat, but doesn't on GlassFish

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: 2.2
    • Component/s: code
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

      Description

      Please see attached war file.

      I do have Tomcat 5.5 with Metro 1.4, and GF 2.1 with Metro 1.4 installed. I'm
      able to deploy the war to Tomcat, but not able to deploy to GF - getting the
      exception below. This is blocking the tools integration.

      com.sun.xml.ws.transport.http.servlet.WSServletException: WSSERVLET11: failed to
      parse runtime descriptor: runtime modeler error: Wrapper class
      test.jaxws.Operation is not found. Have you run APT to generate them?
      com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:118)
      org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4632)
      org.apache.catalina.core.StandardContext.start(StandardContext.java:5312)
      com.sun.enterprise.web.WebModule.start(WebModule.java:353)
      com.sun.enterprise.web.LifecycleStarter.doRun(LifecycleStarter.java:58)
      com.sun.appserv.management.util.misc.RunnableBase.runSync(RunnableBase.java:304)
      com.sun.appserv.management.util.misc.RunnableBase.run(RunnableBase.java:341)
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      java.util.concurrent.FutureTask.run(FutureTask.java:123)
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      java.lang.Thread.run(Thread.java:613)

      Caused by: com.sun.xml.ws.model.RuntimeModelerException: runtime modeler error:
      Wrapper class test.jaxws.Operation is not found. Have you run APT to generate them?
      com.sun.xml.ws.model.RuntimeModeler.getClass(RuntimeModeler.java:287)
      com.sun.xml.ws.model.RuntimeModeler.processDocWrappedMethod(RuntimeModeler.java:596)
      com.sun.xml.ws.model.RuntimeModeler.processMethod(RuntimeModeler.java:543)
      com.sun.xml.ws.model.RuntimeModeler.processClass(RuntimeModeler.java:371)
      com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:258)
      com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:322)
      com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:188)
      com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parseAdapters(DeploymentDescriptorParser.java:253)
      com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parse(DeploymentDescriptorParser.java:147)
      com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:108)
      ... 12 more

        Activity

        snajper added a comment -

        Created an attachment (id=1)
        War file

        Martin Grebac added a comment -

        Old issue, Updating priority, Marking as waived for 2.2, need to retest with latest metro.

        Martin Grebac added a comment -

        Works fine with GF 3.1.2 and latest metro.


          People

          • Assignee:
            Martin Grebac
            Reporter:
            snajper
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: