Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: current
    • Fix Version/s: current
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      15

      Description

      Hello,

      I believe that I have discovered an issue around MTOM/XOP SOAP response
      generation. I have tested Metro 1.1. and 1.4 with Firefox 3.6 and IE8.

      It could be also a browser issue.

      The problem is the Content-Type HTTP response header. It seems to be not parsed
      in the browser xhr object properly resulting in XML response null.
      (http://www.w3.org/TR/soap12-mtom/ 3.2. Serialization of a SOAP message)

      In the header there comes something like this:

      multipart/related;start="<rootpart*8d077d6b-19a4-4725-9ee2-f87f841541ad@example.jaxws.sun.com>";type="application/xop+xml";boundary="uuid:8d077d6b-19a4-4725-9ee2-f87f841541ad";start-info="text/xml"

      kind regards,
      P.

        Activity

        Martin Grebac added a comment -

        Hi, do you have a testcase for this? Did you try with later releases of metro?


          People

          • Assignee:
            Martin Grebac
            Reporter:
            jnoob
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: