mq
  1. mq
  2. MQ-194

imqcmd can't connect to broker when conflicting ports are specified

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: broker-core
    • Labels:
      None
    • Environment:

      Glassfish v4.0 b45, Windows

      Description

      Message broker stops responding when conflicting ports are specified.
      To reproduce the problem
      1.Edit glassfish3\mq\lib\props\broker\default.properties
      imq.admin.tcp.port=1000
      imq.jms.tcp.port=1000
      2.Start imqbrokerd
      imqbrokerd
      3.Connect to imqbrokerd from imqcmd
      imqcmd shutdown bkr
      4.Unable to shutdown as connection to the imqbrokerd is not established.

      The problem can be reproduced by changing the port number after the imqbrokerd has been started.
      1.Start imqbrokerd.
      2.imqcmd update svc -n admin -o port=1000
      3.imqcmd update svc -n jms -o port=1000
      4.imqcmd shutdown bkr
      Unable to shutdown.

      I opened GLASSFISH-19025 for the same issue, but David asked me to refile the same issue against MQ.

        Activity

        amyk added a comment - - edited

        1. As expected, the broker log shows the 'admin' service is not started because of "Address already in use"

        [#|2013-02-16T17:26:53.678-0800|SEVERE|5.0|imq.log.Logger|_ThreadID=1;_ThreadName=main;|ERROR [B3009]: Unable to start service admin: [B4001]: Unable to open protocol tcp for admin service using com.sun.messaging.jmq.jmsserver.net.tcp.TcpProtocol: Address already in use

        2. As expected, imqcmd using -b <broker-host:portmapper-port> will fail immediately with JMSException "[C4098]: Unknown broker service: admin"

        Note: imqcmd -b hostName:portNumber option is for broker's portmapper - filed MQ-281 to clarify this explicitly in documentation

        3. The 'jms' service port works as expected


          People

          • Assignee:
            amyk
            Reporter:
            tak09
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: