mq
  1. mq
  2. MQ-230

Enhance JMSRA to include cluster name in a generated subscription name

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0-RI (JMS2.0), 5.0
    • Component/s: mq-ra
    • Labels:
      None

      Description

      JMS_SPEC-103 proposes that the subscription name generated by a resource adapter should be composed of (1) a name which uniquely identifies the deployed MDB within thin the cluster as well as (2) a name which uniquely identifies the application server cluster.

      MQ-193 already covers the implementation of (1). This issue requests implementation of (2).

      Implementation work should not begin until JMS_SPEC_103 has been incorporated in the JMS 2.0 specification.

      Implementation may also be dependent on the addition of a new feature to the Java EE platform specification to make the cluster name available to a resource adapter.

        Issue Links

          Activity

          Nigel Deakin added a comment -

          Since implementation of MQ-193 has not started yet I am going to merge this issue with that one.

          Closing this issue (as a duplicate of MQ-193).


            People

            • Assignee:
              Nigel Deakin
              Reporter:
              Nigel Deakin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: