odejava
  1. odejava
  2. ODEJAVA-1

GeomBox and GeomTriMesh will not collide

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: All

    • Issuezilla Id:
      1

      Description

      There appears to be a bug with the collision between boxes and trimesh, at least
      in linux. If not an Odejava bug - then one in the CarTerrainExample demo.

      Spheres are colliding fine but boxes are not. I thought it was just my
      program (a truck on some random terrain) but reviewing the car terrain
      demo it seems to affects it as well (hit the boxes then do a U-turn and
      look at them - or better just create a box to drop somewhere in the
      middle).

      My efforts to reproduce the problem with the TriMeshExample were not successful

      • but the fact that it exists in two demos where large terrain and vehicles are
        used seems to indicate a problem. Both demos use different methods to get the
        terrain - one is loaded, the other generated.

      Will.

      1. CarTerrain.java
        19 kB
        willdenniss
      1. Screenshot-48.png
        34 kB

        Activity

        willdenniss added a comment -

        Created an attachment (id=1)
        screenshot of problem - look at the box

        willdenniss added a comment -

        Created an attachment (id=2)
        modified example to better show problem

        willdenniss added a comment -

        This problem was caused by a bug, most likely in GCC. OPCODE needs to be
        compiled with the optimisation level -O1 rather than -O2 (which is the default)
        to workaround this bug. This had been done in the past - but the change to
        Makefile was not committed.

        The makefile has now been updated in CVS, as has the binary Linux library.

        All tests in linux which previously failed, now pass.

        Will.


          People

          • Assignee:
            odejava-issues
            Reporter:
            willdenniss
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: