opensso
  1. opensso
  2. OPENSSO-5278

Email context in garbage for Request OTP code

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: build8a
    • Component/s: authentication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: PC

    • Issuezilla Id:
      5,278

      Description

      Build 7a (07/16 nightly)
      JBOSS 5.1 GA running locale en_US.UTF-8
      Firefox 3.0 on zh-cn

      1. Login to OpenSSO Enterprise console as amadmin.
      2. Click on the link for the default realm.
      3. Click on the “Authentication� tab.
      4. Under “Authentication Chaining�, create a new authentication configuration
      named “HOTPService�.
      Enter the “DataStore� authentication module instance as “REQUIRED� and the
      “HOTP� authentication module
      instance as “REQUIRED�.
      5. Create a new user named “otuser� with the password “mysecret�.
      6. Edit the otuser user profile by entering a mobile
      number with the carrier's domain name in the
      “Telephone Number� and a valid e-mail address in
      “Email Address�. Save the changes.
      7. Logout.
      8. In the client browser, access the URL
      http://host:port//UI/Login?service=HOTPService&gx_charset=UTF-8.
      9. In the DataStore authentication login screen enter the user name “otuser� and
      password “mysecret�.
      10. In the HOTP authentication login screen click “Request OTP Code�. Within a
      minute or two the OTP code should arrive at the email account and the mobile
      number specified in the user profile.

      After receiving the email, its subject in Chinese character, but it contents are
      in garbage, like below:

      ?? OpenSSO ?????: 12841342

      Is it possible not using UTF-8 encoding to generate the email contents?

      1. CRT_approved:5278
        0.1 kB
        veiming
      2. CRT_submittal:5278
        22 kB
        qcheng

        Activity

        qcheng added a comment -

        able to reproduce the issue by setting Firefox locale to zh-cn,
        targeting for build 8a

        qcheng added a comment -

        Created an attachment (id=9176)
        CRT_submittal:5278

        veiming added a comment -

        Created an attachment (id=9179)
        CRT_approved:5278

        qcheng added a comment -

        fixed
        note: need to set character encoding to "UTF-8" when viewing the Email.

        charlesliu added a comment -

        The issue still exists in 08/21 nightly build

        Have set character encoding to "UTF-8" when viewing the Email.

        sh20373 added a comment -
            • Issue 5464 has been marked as a duplicate of this issue. ***
        qcheng added a comment -

        The fix is in main trunk only (build 9), not in the build 8 branch,
        20090821a_build8 mentioned in issue 5464 is the nightly for build
        8 branch, not the nightly for the main trunk.
        Please verify the fix in the nightly for trunk only.

        sh20373 added a comment -

        Yes, I fixed verified in the latest nightly(trunk).

        pierrot added a comment -

        Marking as verified since Hanaki verified it.


          People

          • Assignee:
            qcheng
            Reporter:
            charlesliu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: