open-jbi-components
  1. open-jbi-components
  2. OPEN_JBI_COMPONENTS-514

Monitoring: When resuming suspended instances, some of the instances run forever

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: BPEL SE
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      514

      Description

      Monitoring: When resuming suspended instances by processId, some of the
      instances run forever

      I have attached the screenshots - please have a look

      This is reproduced in CAPS6 EA3 and monitoring build 21-04-2008

      Steps to reproduce:-

      1. I have attached the Rethrow Project. Deploy and Run the test
      "FirstLevelScopeCatch" with 100 concurrent instances.

      2. use command s
      processId="

      {http://enterprise.netbeans.org/bpel/Rethrow/FirstLevelScopeProcess}

      FirstLevelScopeProcess"

      3. This will suspend the instances. Wait for some time and use the resume command

      4. r
      processId="

      {http://enterprise.netbeans.org/bpel/Rethrow/FirstLevelScopeProcess}

      FirstLevelScopeProcess"

      5. Now display the status of running instances. It will show some resumed
      instances running forever

      1. InstancesKeepRunning.JPG
        134 kB
      2. Picture 1.png
        153 kB
      3. SuspendNResume.JPG
        124 kB

        Issue Links

          Activity

          deepakhp added a comment -

          I verified with latest builds. Looks like the issue is not resolved.
          I verified with the attached project with 4 concurrent threads.
          Also see the attached screen shot.

          deepakhp added a comment -

          Created an attachment (id=352)
          Screen Shot

          deepakhp added a comment -

          Created an attachment (id=353)
          Sample Project

          deepakhp added a comment -

          Apologies, was testing with older bpel monitor tool.

          Tested with the latest bpel monitor tool.
          I am able to suspend and resume all the 100 instances.

          deepakhp added a comment -

          Closing


            People

            • Assignee:
              mei_wu
              Reporter:
              senthilprabhut
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: