phoneme
  1. phoneme
  2. PHONEME-55

open of /tmp/.qtvfb-mouse-0 failed

    Details

    • Type: Task Task
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Fedora 8
      qt2.3.2
      phoneme-advanced-MR2-b97-2007
      sh4 platform

      Description

      Hello phoneme develop team,

      I'm porting phoneme to ST's sh4 platform,now the error occurs when run midlet on target board:
      open of /tmp/.qtvfb-mouse-0 failed.
      My building is based on qt2.3.2 embedded.

      The following is my config:

      qt2.3.2:
      ./configure -xplatform linux-sh4-g++ -qconfig pmea -no-qvfb -depths 16,32 -thread -qt-libpng -system-jpeg -gif -L/opt/STM/STLinux2.3/devkit/sh4/target/usr/lib -ljpeg

      phoneme:
      make -C $TOP_DIR/cdc/build/linux-sh4-stlinux \
      JDK_HOME=/usr/local/lib/java/j2sdk1.4.2_19 \ GNU_TOOLS_DIR=/opt/STM/STLinux2.3/devkit/sh4/target/bin \ CVM_TARGET_TOOLS_PREFIX=/opt/STM/STLinux2.3/devkit/sh4/target/bin/sh4-linux- \
      J2ME_CLASSLIB=basis \
      ENABLE_PCSL=true \
      PCSL_DIR=$TOP_DIR/pcsl \
      PCSL_PLATFORM=linux_sh4_gcc \
      NETWORK_MODULE=bsd/generic \
      AWT_IMPLEMENTATION=qt \
      QT_TARGET_DIR=/csm/working/qt-2.3.2 \
      QT_VERSION=2 \
      QTEMBEDDED=true \
      QTOPIA=false \
      USE_QVFB=false \
      USE_QT_FB=true \
      CVM_OPTIMIZED=false \
      CVM_VERBOSE=true \
      CVM_JVMDI=false \
      CVM_MTASK=false \
      TOOLS_DIR=$TOP_DIR/tools \
      MIDP_DIR=$TOP_DIR/midp \
      USE_MIDP=true \
      CVM_PRELOAD_LIB=true \
      CVM_JIT=false \
      PCSL_CPU=sh4 \
      USE_QWS=true \
      TARGET_CPU=sh4

      After building,modifiy runMidlet script,add the following line:
      -Dsun.boot.class.path=/stlinux/maze.jar
      Then,cd phoneme_advanced_MR2/cdc/build/linux-sh4-stlinux/midp/midp-linux-fb-gcc/bin/sh4,
      execute "./installMidlet file:////stlinux/maze.jar",then the error occurs:
      open of /tmp/.qtvfb-mouse-0 failed.

      I have do the same work on ARM platform before and it's ok,
      but failed and got this error on sh4.
      Can you give me some advice?

      Thanks& best regards.

      Levi@China.Dlovt

        Activity

        dakalv created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            dakalv
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: