Issue Details (XML | Word | Printable)

Type: New Feature New Feature
Status: Open Open
Priority: Major Major
Assignee: Unassigned
Reporter: msnicklous
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.

Ajax: Change name "JavaScript Portlet" to ... something less confusing

Created: 13/Dec/13 10:41 AM   Updated: 14/Jan/14 05:31 PM
Component/s: Stateful Ajax Support
Affects Version/s: None
Fix Version/s: None

Time Tracking:
Not Specified

Participants: kito75 and msnicklous

 Description  « Hide

Reference: Ajax Proposal 2b

The term "JavaScript Portlet" for client-side code is confusing as it sounds as though the portlet would actually be running in JavaScript on the client, which is not the case.

Instead, the "JavaScript Portlet" is a piece of JavaScript code provided by the portlet for handling the portlet UI.

I understand the conflict, but don't have a good naming proposal right offhand, so please provide better suggestions.

No work has yet been logged on this issue.