portletspec3
  1. portletspec3
  2. PORTLETSPEC3-38

Ajax: Change name "JavaScript Portlet" to ... something less confusing

    Details

    • Type: New Feature New Feature
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Component/s: Stateful Ajax Support
    • Labels:
      None

      Description

      Reference: Ajax Proposal 2b

      The term "JavaScript Portlet" for client-side code is confusing as it sounds as though the portlet would actually be running in JavaScript on the client, which is not the case.

      Instead, the "JavaScript Portlet" is a piece of JavaScript code provided by the portlet for handling the portlet UI.

      I understand the conflict, but don't have a good naming proposal right offhand, so please provide better suggestions.

        Activity

        Hide
        kito75 added a comment -

        How about JavaScript Portlet UI?

        Show
        kito75 added a comment - How about JavaScript Portlet UI?

          People

          • Assignee:
            Unassigned
            Reporter:
            msnicklous
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: