portletspec3
  1. portletspec3
  2. PORTLETSPEC3-39

Ajax: Improve version specification for dependencies / resources

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Component/s: Stateful Ajax Support
    • Labels:
      None

      Description

      Reference: Ajax Proposal 2b

      The current proposal for dependencies calls for either the specification of an exact resource version through use of the <version> tag or a minimum version through the <minVersion> tag.

      Instead, the <minVersion> should be dropped, and a version specification similar to what maven (and OSGi, as I understand it) uses should be provided through the <version> tag.

      Details to be provided ... I think we should use a subset of what is described under the maven link.

        Activity

        Hide
        msnicklous added a comment -

        Done. Specified in a slightly different manner ... see spec Section 28.2.8 "Dependencies".

        Show
        msnicklous added a comment - Done. Specified in a slightly different manner ... see spec Section 28.2.8 "Dependencies".

          People

          • Assignee:
            Unassigned
            Reporter:
            msnicklous
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: