Component/s: Ideas for JSR 362 Extensions
I received a few comments about the portlet state proposal.
1) Refers to issue
PORTLETSPEC3-13. The current proposal adds four methods to handle fragment identifiers: getFragmentIdentifier, setFragmentIdentifier, isFragmentIdentifierPermitted, and setFragmentIdentifierPermitted. The intention of the "permitted" methods is to be able to suppress a fragment identifier set by the portal. A better way to accomplish that goal would be to drop both of the "permitted" methods and redefine the "get" method to return either the fragment identifier previously set
by the portal, or that set by the portlet. The portlet could then use the setter to set the value to "null" if no fragment identifier is desired.
2) Refers to issue PORTLETSPEC3-21. The "write" methods on BaseURL that take an Appendable argument should be renamed to "append" and should return the modified Appendable input object in order to allow for chaining.
3) In the new MutablePortletParameters#setParameter(String, String) method, a null value for the array or an empty array should be allowed.
4) Add a new MutablePortletParameters#getParameterNames(String) method that returns a Set, overriding the corresponding PortletParameters method. In the mutable case, removing a parameter from the set will remove that parameter from the PortletParameters object.