portletspec3
  1. portletspec3
  2. PORTLETSPEC3-43

In the Portlet State proposal, shorten the method names in the PortletParameters and MutablePortletParameters classes

    Details

      Description

      The Portlet State proposal defines the PortletParameters and MutablePortletParameters classes for reading and updating parameters. Many of the method names in these classes have the word "Parameter" in their signature:

      getParameter(String)
      getParameterNames()
      getParameterValues(String)
      setParameter(String, String)
      setParameter(String, String...)
      

      These names are very long and also redundant, since both classes deal exclusively with parameters. The method names should be shortened.

        Activity

        Hide
        msnicklous added a comment -

        The following naming would shorten the method names and reduce redundancy. This suggestion also makes the getter & setter naming more symmetrical and more in line with bean naming conventions.

        getValue(String)
        getNames()
        getValues(String)
        setValue(String, String)
        setValues(String, String...)
        
        Show
        msnicklous added a comment - The following naming would shorten the method names and reduce redundancy. This suggestion also makes the getter & setter naming more symmetrical and more in line with bean naming conventions. getValue( String ) getNames() getValues( String ) setValue( String , String ) setValues( String , String ...)
        Hide
        msnicklous added a comment -

        Done. See javadoc for PortletParameters.

        Show
        msnicklous added a comment - Done. See javadoc for PortletParameters .

          People

          • Assignee:
            msnicklous
            Reporter:
            msnicklous
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: