Issue Details (XML | Word | Printable)

Key: SAILFIN-1032
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Yamini K B
Reporter: sonymanuel
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
sailfin

Enabling callflow monitoring pauses SIP traffic for 8-10 seconds.

Created: 11/Jul/08 07:21 AM   Updated: 23/Jul/08 12:51 AM   Resolved: 23/Jul/08 12:51 AM
Component/s: admin
Affects Version/s: 1.0
Fix Version/s: milestone 1

Time Tracking:
Not Specified

File Attachments: 1. Text File jstack-enable-cf.out.1 (101 kB) 11/Jul/08 07:22 AM - sonymanuel

Environment:

Operating System: All
Platform: All


Issuezilla Id: 1,032
Tags: shark-approved
Participants: prasads, sanandal, sonymanuel and Yamini K B


 Description  « Hide

******************************************************************************************************

  • Template v0.1 ( 05/01/08 )
  • Sailfin Stress test issue
    ******************************************************************************************************
    Sailfin Build : 37d
    Cluster size : N/A. Test is on DAS
    Happens in a single instance (y/n) ? : Yes
    Test id : st3_1_invite_proxy
    Location of the test : as-telco-sqe/stress-ws/invite
    JDK version : 1.6.0_06
    CLB used : No
    HW LB used : No.
    ********************************************************************************

When callflow is enabled seems like the container freezes for a while. This
cause lots of calls to back up in the sipp clients. If this number is high the
server never recovers and does not process any more requests.



sonymanuel added a comment - 11/Jul/08 07:22 AM

Created an attachment (id=549)
jstack output immediately after callflow is enabled.


sonymanuel added a comment - 11/Jul/08 08:31 AM

This is also the case if you enable callflow first and then start traffic.


sanandal added a comment - 14/Jul/08 03:59 AM

Modifying keyword to shark-approved


sanandal added a comment - 14/Jul/08 04:00 AM

Modifying keyword to shark-approved


sanandal added a comment - 14/Jul/08 04:26 AM

update keyword


sonymanuel added a comment - 14/Jul/08 04:46 AM

With 10 cps, there is a pause but the system easily recovers. Even at this low
rate when I access the data through Admin GUI there seems to be some deadlock
which causes the instance to stop processing


Yamini K B added a comment - 14/Jul/08 09:54 PM

I'm unable to reproduce the problem. I went upto 50cps without any issues. The
requests completed fine and am able to view the callflow data in GUI. Some points:

1. Developer mode SailFin instance running on Solaris sparc
2. I'm using QL's simple invite sample
3. Running 'sipp' remotely
4. Accessing GUI also remotely


prasads added a comment - 20/Jul/08 10:21 PM

Marking as shark-approved


Yamini K B added a comment - 23/Jul/08 12:51 AM

Following parameters need to be tuned when using call flow under load:

<jvm-options>-Dcom.sun.enterprise.callflow.qsize=xxx</jvm-options>
<jvm-options>-Dcom.sun.enterprise.callflow.containertime.qsize=xxx</jvm-options>
<jvm-options>-Dcom.sun.enterprise.callflow.sleepms=xxx</jvm-options>

I haven't encountered pauses in my testing with load of 10cps (even without any
tuning)

However, I've incorporated the fixes suggested by Harpreet to avoid freezes and
reduce memory leak.