sailfin
  1. sailfin
  2. SAILFIN-1067

Unable to Create Connector Connection Pool Using Gui

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: sip_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Hi

      I am unable to create Connector Connection Pool using SailFin admin gui, when
      Connector Module is deployed only on cluster.Steps to reproduce

      1) Deploy the connector module on Cluster (it should be deployed only on
      cluster not on DAS).

      2) Try creating the Connector Connection Pool using admin gui. It will throw
      some wierd errors on gui.

      Please note that this works if you deploy using asadmin command. Also this
      problem cannot be replicated if Connector Module is deployed on DAS and cluster
      both. It should be deployed only on cluster to replicate this problem.

        Activity

        Jagadish added a comment -

        Could you post the exception messages in GUI and in server.logs ?

        akhilesh1981 added a comment -

        *********************************GUI LOGS*****************************
        message

        descriptionThe server encountered an internal error () that prevented it from
        fulfilling this request.

        exception

        javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
        while attempting to process a 'command' event for 'nextButton'.
        root cause

        java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while
        attempting to process a 'command' event for 'nextButton'.
        root cause

        java.lang.reflect.InvocationTargetException
        root cause

        java.lang.RuntimeException:
        com.sun.enterprise.connectors.ConnectorRuntimeException: ClassNot Found :
        com.ericsson.iptv.iap.rtspconnector.managedconnection.ManagedConnectionFactoryIm
        pl
        root cause

        com.sun.enterprise.connectors.ConnectorRuntimeException: ClassNot Found :
        com.ericsson.iptv.iap.rtspconnector.managedconnection.ManagedConnectionFactoryIm
        pl
        note The full stack traces of the exception and its root causes are available
        in the Sun GlassFish Communications Server 0.5 logs.
        *******************************END GUI LOGS*********************************

        ******************************SERVER LOGS************************************
        PWC1406: Servlet.service() for servlet FacesServlet threw exception
        java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while
        attempting to process a 'command' event for 'nextButton'. at
        com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers
        (LayoutElementBase.java:426) at
        com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers
        (LayoutElementBase.java:398) at
        com.sun.jsftemplating.layout.event.CommandActionListener.invokeCommandHandlers
        (CommandActionListener.java:132) at
        com.sun.jsftemplating.layout.event.CommandActionListener.processAction
        (CommandActionListener.java:80) at javax.faces.event.ActionEvent.processListener
        (ActionEvent.java:77) at javax.faces.component.UIComponentBase.broadcast
        (UIComponentBase.java:746) at javax.faces.component.UICommand.broadcast
        (UICommand.java:368) at com.sun.webui.jsf.component.WebuiCommand.broadcast
        (WebuiCommand.java:160) at javax.faces.component.UIViewRoot.broadcastEvents
        (UIViewRoot.java:447) at javax.faces.component.UIViewRoot.processApplication
        (UIViewRoot.java:752) at com.sun.faces.lifecycle.InvokeApplicationPhase.execute
        (InvokeApplicationPhase.java:97) at com.sun.faces.lifecycle.LifecycleImpl.phase
        (LifecycleImpl.java:251) at com.sun.faces.lifecycle.LifecycleImpl.execute
        (LifecycleImpl.java:117) at
        com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.execute
        (PartialTraversalLifecycle.java:80) at javax.faces.webapp.FacesServlet.service
        (FacesServlet.java:244) at
        com.sun.enterprise.tools.admingui.servlet.DelayedInitFacesServlet.service
        (DelayedInitFacesServlet.java:89) at
        org.apache.catalina.core.ApplicationFilterChain.servletService
        (ApplicationFilterChain.java:411) at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
        (ApplicationFilterChain.java:317) at
        org.apache.catalina.core.ApplicationFilterChain.doFilter
        (ApplicationFilterChain.java:198) at
        com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:240) at
        org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
        (ApplicationFilterChain.java:230) at
        org.apache.catalina.core.ApplicationFilterChain.doFilter
        (ApplicationFilterChain.java:198) at
        org.apache.catalina.core.StandardWrapperValve.invoke
        (StandardWrapperValve.java:288) at
        org.apache.catalina.core.StandardContextValve.invokeInternal
        (StandardContextValve.java:271) at
        org.apache.catalina.core.StandardContextValve.invoke
        (StandardContextValve.java:202) at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
        at org.apache.catalina.core.StandardPipeline.doInvoke
        (StandardPipeline.java:577) at com.sun.enterprise.web.WebPipeline.invoke
        (WebPipeline.java:94) at
        com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke
        (PESessionLockingStandardPipeline.java:98) at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
        at org.apache.catalina.core.StandardPipeline.doInvoke
        (StandardPipeline.java:632) at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080) at
        org.apache.catalina.core.StandardEngineValve.invoke
        (StandardEngineValve.java:150) at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
        at org.apache.catalina.core.StandardPipeline.doInvoke
        (StandardPipeline.java:577) at org.apache.catalina.core.StandardPipeline.invoke
        (StandardPipeline.java:571) at org.apache.catalina.core.ContainerBase.invoke
        (ContainerBase.java:1080) at org.apache.coyote.tomcat5.CoyoteAdapter.service
        (CoyoteAdapter.java:272) at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter
        (DefaultProcessorTask.java:637) at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess
        (DefaultProcessorTask.java:568) at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process
        (DefaultProcessorTask.java:813) at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask
        (DefaultReadTask.java:341) at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask
        (DefaultReadTask.java:263) at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask
        (DefaultReadTask.java:214) at
        com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265) at
        com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run
        (SSLWorkerThread.java:106) Caused by:
        java.lang.reflect.InvocationTargetException at
        sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at
        sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke
        (DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke
        (Method.java:597) at
        com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke
        (Handler.java:422) at
        com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers
        (LayoutElementBase.java:424) ... 47 more Caused by: java.lang.RuntimeException:
        com.sun.enterprise.connectors.ConnectorRuntimeException: ClassNot Found :
        com.ericsson.iptv.iap.rtspconnector.managedconnection.ManagedConnectionFactoryIm
        pl at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:124)
        at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:75) at
        com.sun.enterprise.tools.admingui.handlers.ConnectorsHandlers.getConnectorConnec
        tionPoolProps(ConnectorsHandlers.java:1349) at
        com.sun.enterprise.tools.admingui.handlers.ConnectorsHandlers.updateConnectorCon
        nectionPoolWizard(ConnectorsHandlers.java:617) ... 53 more Caused by:
        com.sun.enterprise.connectors.ConnectorRuntimeException: ClassNot Found :
        com.ericsson.iptv.iap.rtspconnector.managedconnection.ManagedConnectionFactoryIm
        pl at com.sun.enterprise.connectors.util.ConnectorConfigParserUtils.loadClass
        (ConnectorConfigParserUtils.java:470) at
        com.sun.enterprise.connectors.util.ConnectorConfigParserUtils.introspectJavaBean
        (ConnectorConfigParserUtils.java:151) at
        com.sun.enterprise.connectors.util.MCFConfigParserImpl.getJavaBeanProps
        (MCFConfigParserImpl.java:181) at
        com.sun.enterprise.connectors.ConnectorConfigurationParserServiceImpl.getConnect
        orConfigJavaBeans(ConnectorConfigurationParserServiceImpl.java:210) at
        com.sun.enterprise.connectors.ConnectorConfigurationParserServiceImpl.getMCFConf
        igProps(ConnectorConfigurationParserServiceImpl.java:158) at
        com.sun.enterprise.connectors.ConnectorRuntime.getMCFConfigProps
        (ConnectorRuntime.java:726) at
        com.sun.enterprise.admin.mbeans.ResourcesMBean.getMCFConfigProps
        (ResourcesMBean.java:2310) at sun.reflect.NativeMethodAccessorImpl.invoke0
        (Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke
        (NativeMethodAccessorImpl.java:39) at
        sun.reflect.DelegatingMethodAccessorImpl.invoke
        (DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke
        (Method.java:597) at com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean
        (MBeanHelper.java:381) at
        com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean
        (MBeanHelper.java:364) at com.sun.enterprise.admin.config.BaseConfigMBean.invoke
        (BaseConfigMBean.java:470) at
        com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke
        (DefaultMBeanServerInterceptor.java:836) at
        com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761) at
        sun.reflect.GeneratedMethodAccessor26.invoke(Unknown Source) at
        sun.reflect.DelegatingMethodAccessorImpl.invoke
        (DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke
        (Method.java:597) at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke
        (ProxyClass.java:90) at $Proxy1.invoke(Unknown Source) at
        com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke
        (SunoneInterceptor.java:304) at
        com.sun.enterprise.interceptor.DynamicInterceptor.invoke
        (DynamicInterceptor.java:174) at
        com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:119) ... 56
        more
        *****************************END SERVER LOGS*****************************

        Jagadish added a comment -

        Yes, this is a bug for GlassFish Connector module.
        Created the following bug.

        https://glassfish.dev.java.net/issues/show_bug.cgi?id=5423

        jagadesh added a comment -

        "This bug will be scrubbed and will be upgraded for next relevant milestone builds".

        prasads added a comment -

        Re-assigning to Jagadish for further investigation.

        prasads added a comment -

        Bumping up the priority to P3

        Jagadish added a comment -

        Fixed in GlassFish

        Refer:
        https://glassfish.dev.java.net/issues/show_bug.cgi?id=5423
        for fix & build number information


          People

          • Assignee:
            Jagadish
            Reporter:
            akhilesh1981
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: