sailfin
  1. sailfin
  2. SAILFIN-1133

BLOCKING: Ericsson FT and Sample Dev Tests Failing after your AR Fix.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: tests
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,133

      Description

      After you AR Fix ericsson FT and Sample Dev Tests are failing. Ericsson FTs
      remains in hanging state.

      Server.log is showing below error:
      [#|2008-09-05T16:38:07.876+0530|SEVERE|sun-glassfish-comms-server1.0|grizzly|_ThreadID=210;_ThreadName=SipContainer-serversWorkerThread-5060-6;_RequestID=6a1ebabd-112e-4f00-b060-39c2315c321e;|WorkerThreadImpl
      unexpected exception:
      java.lang.ClassCastException: $Proxy43
      at
      com.ericsson.ssa.sip.SipServletRequestImpl.isLocalRoute(SipServletRequestImpl.java:1506)
      at com.ericsson.ssa.sip.LocalRouteManager.dispatch(LocalRouteManager.java:116)
      at
      com.ericsson.ssa.container.sim.ApplicationDispatcher.dispatchViaStatelessProxy(ApplicationDispatcher.java:796)
      at
      com.ericsson.ssa.container.sim.ApplicationDispatcher.invokeServletDispatchers(ApplicationDispatcher.java:591)
      at
      com.ericsson.ssa.container.sim.ApplicationDispatcher.dispatch(ApplicationDispatcher.java:335)
      at com.ericsson.ssa.sip.FSM$1.call(FSM.java:127)
      at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:169)

      #]

        Activity

        naman_mehta added a comment -

        It is blocking issue so marked as P1.

        naman_mehta added a comment -

        Assigning this bug to Per.

        naman_mehta added a comment -

        Running Ericsson FT on latest workspace, it is showing below error in
        server.log. Ericsson FT is not moving further still in hanging state.

        [#|2008-09-08T18:18:48.550+0530|SEVERE|sun-glassfish-comms-server1.0|javax.enterprise.system.container.sip|_ThreadID=210;_ThreadName=SipContainer-serversWorkerThread-5060-9;_RequestID=f73e765c-5070-46fe-850e-5cb5f134d762;|Exception
        allocating servlet
        java.lang.IllegalStateException: You cannot modify a system header
        at com.ericsson.ssa.sip.UriPolicyProxy.invoke(UriPolicyProxy.java:104)
        at $Proxy44.setTransportParam(Unknown Source)
        at
        com.ericsson.eas.ft.SSA_1_1.servlet.tm20_2_b2buahelper.Servlet.doInvite(Servlet.java:83)
        at javax.servlet.sip.SipServlet.doRequest(SipServlet.java:56)
        at javax.servlet.sip.SipServlet.service(SipServlet.java:45)
        at
        com.ericsson.ssa.container.sim.SipServletFacade.service(SipServletFacade.java:85)
        at
        com.ericsson.ssa.container.sim.SipServletWrapper.invokeServlet(SipServletWrapper.java:137)
        at
        com.ericsson.ssa.container.sim.ServletDispatcher.invoke(ServletDispatcher.java:313)
        at
        com.ericsson.ssa.container.sim.ApplicationDispatcher.invokeServletDispatchers(ApplicationDispatcher.java:543)
        at
        com.ericsson.ssa.container.sim.ApplicationDispatcher.dispatch(ApplicationDispatcher.java:335)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:50)
        at
        com.ericsson.ssa.container.sim.ApplicationDispatcher.next(ApplicationDispatcher.java:872)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at com.ericsson.ssa.sip.LocalRouteManager.next(LocalRouteManager.java:95)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at com.ericsson.ssa.sip.DialogManager.next(DialogManager.java:508)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at com.ericsson.ssa.sip.dns.ResolverManager.next(ResolverManager.java:187)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at
        com.ericsson.ssa.sip.persistence.ReplicationManager.next(ReplicationManager.java:102)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at
        com.ericsson.ssa.sip.transaction.TransactionManager.invokeCreatedOrFetchedServerTransaction(TransactionManager.java:220)
        at
        com.ericsson.ssa.sip.transaction.TransactionManager.next(TransactionManager.java:271)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at
        com.ericsson.ssa.container.GrizzlyNetworkManager.next(GrizzlyNetworkManager.java:969)
        at com.ericsson.ssa.sip.LayerHelper.next(LayerHelper.java:57)
        at
        com.ericsson.ssa.container.MessageProcessorFilter.processMessage(MessageProcessorFilter.java:374)
        at
        com.ericsson.ssa.container.MessageProcessorFilter.execute(MessageProcessorFilter.java:295)
        at
        com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
        at
        com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:67)
        at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:56)
        at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:169)

        #]
        pellepedro added a comment -

        This issue is likely related to multiple causes i.e. code modifications, updates
        of FT test suite, and the function test tool itself.

        The hanging seems to be related to TLS, while the exceptions are code isses,
        which are under investigation/fixing.

        The FT test suite is also in the process of beeing updated.

        pellepedro added a comment -

        This issues should be fixed after sync of the FT test suite.

        Ericsson FT test is ~94% as of 15 Sept.

        Last run

        Time executed: 2008-09-15 12:18 CEST
        ExecTime: 3196.226 seconds
        TestCases: 414
        Passing: 390
        Failing: 24
        Errors: 0
        Expected: 95.12%
        PASS %: 94.20%

        Unexpected failing or error test cases
        --------------------------------------
        Number: 4

        com.ericsson.eas.ft.SSA_1_1.test.SSA_1_1_Tester::test20_29
        com.ericsson.eas.ft.SSA_1_1.test.SSA_1_1_Tester::test20_3
        com.ericsson.eas.ft.scenarios.test.ScenariosTester::test7_84
        com.ericsson.eas.ft.scenarios.test.ScenariosTester::test7_24

        Expected to fail but succeeded
        --------------------------------------
        Number: 2

        com.ericsson.eas.ft.SSA_1_1.test.SSA_1_1_Tester::test20_37
        com.ericsson.eas.ft.SSA_1_1.test.SSA_1_1_Tester::test20_36

        Email generated by Sailfin nightly build


          People

          • Assignee:
            pellepedro
            Reporter:
            naman_mehta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: