sailfin
  1. sailfin
  2. SAILFIN-1182

487 to INVITE is not received for b2bua cancelling

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: sip_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,182

      Description

      Please see the e-mail thread for details.

      http://www.nabble.com/Problem-with-CANCEL-related-handling-with-2-B2BUA-applications-
      to19533760.html

      1. issue_1182.tar.gz
        1.15 MB
        echeung
      2. server.log.gz
        19 kB
        echeung

        Activity

        echeung added a comment -

        More info: Making CCF a record-route, supervised proxy, the problem is the
        same. RR does not receive the 487 response to the INVITE request.

        yule_jie added a comment -

        Cannot reproduce this problem. I have tried
        1. (CCF is a non-record-route, non-supervised proxy)
        2. (CCF is a record-route, supervised proxy)

        Both of them worked for me. RR received 487. Can you provide your test servlets?

        echeung added a comment -

        Created an attachment (id=752)
        application war files and server.log

        echeung added a comment -

        Attached a tar.gz containing the 3 applications:
        RR - rerouteUponFailureTest.war
        CCF - ccfTest.war
        NAT - noAnswerTimeoutTest.war

        and server.log. Note that noAnswerTimeoutTest logs receipt of 487 response from
        external UA. But rerouteUponFailureTest does not log receipt of 487.

        Did you run your test on b55, or on the newest code?

        yule_jie added a comment -

        Please try with the latest build.


          People

          • Assignee:
            yule_jie
            Reporter:
            binod
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: