sailfin
  1. sailfin
  2. SAILFIN-1320

[grizzly]NPE at sun.nio.ch.SocketChannelImpl.write()

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: server_lifecycle
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,320

      Description

      Build Version = Sun GlassFish Communications Server 1.0 (build b58-fcs) nightly
      build dated 10/27/2008.

      It has been observed that server is throwing the following NPE when TLS
      transport is used. This the INVITE scenario with UAC -> UAS (sailfin). Here
      "sips" scheme and TLS transport is used with SIPp tool. If no TLS and only with
      sips scheme, then test worked fine.

      [#|2008-10-28T00:07:57.552-0700|SEVERE|sun-glassfish-comms-server1.0|grizzly|_ThreadID=22;_ThreadName=SipContainer-serversWorkerThread-5060-4;_RequestID=3bd3ebcf-a192-4c62-b5da-ce630164f2ba;|WorkerThreadImpl
      unexpected exception:
      java.lang.NullPointerException
      at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:322)
      at com.sun.grizzly.async.TCPAsyncQueueWriter.doWrite(TCPAsyncQueueWriter.java:80)
      at
      com.sun.grizzly.async.AbstractAsyncQueueWriter.doWrite(AbstractAsyncQueueWriter.java:374)
      at
      com.sun.grizzly.async.AbstractAsyncQueueWriter.onWrite(AbstractAsyncQueueWriter.java:291)
      at
      com.sun.grizzly.async.AsyncQueueWriterContextTask.doCall(AsyncQueueWriterContextTask.java:86)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:56)
      at com.sun.grizzly.util.WorkerThreadImpl.processTask(WorkerThreadImpl.java:325)
      at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:184)

      #]

        Activity

        rampsarathy added a comment -

        I was not able to reproduce the issue with the test case that has been provided,
        the test case does not run because of other setup issues where Sailfin is unable
        to create a tls connection with the UAS. I did not see this particular NPE in
        the log file.
        Please provide a scenario to reproduce this

        jagadesh added a comment -

        Ramesh,

        I can reproduce it multiple times with latest nightly build (10/31/2008).
        I sent you an email and we can work on your machine.

        Yes. We need to understand why UAS is closed when SailFin contacted it. Here
        SailFin is producing the NPEs and no useful information is produced in the
        server.log.

        Thanks.

        rampsarathy added a comment -

        this is because the thread attachment was not propagated to the executing
        thread, gave a patch and verified the issue is fixed
        will check in after running the tests

        rampsarathy added a comment -

        fixed in b59

        riyadeeks added a comment -

        can someone help getting SIPP TLS working with sailfin


          People

          • Assignee:
            rampsarathy
            Reporter:
            jagadesh
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: