Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: All

    • Issuezilla Id:
      1,531
    • Tags:

      Description

      Hi,

      we are running an SGCS (V05 P2 B04) cluster.

      A very frequent error that we are facing is that the lifecycle module of SJSMQ
      JMS Resource Adapter seems to prevent the startup of the service instance.
      This should be due to a failure to create connection to localhost:37676 as seen
      to log fragment :

      [#|2008-12-10T16:07:59.592+0100|INFO|sun-glassfish-comms-server1.5|javax.enterprise.resource.resourceadapter|_ThreadID=11;_ThreadName=main;|JMS
      Service Connection URL is :mq://SC_2_2:37676/,mq://SC_2_1:37676/|#]

      [#|2008-12-10T16:07:59.609+0100|INFO|sun-glassfish-comms-server1.5|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=11;_ThreadName=main;|MQJMSRA_RA1101:
      SJSMQ JMS Resource Adapter starting...|#]

      [#|2008-12-10T16:07:59.656+0100|INFO|sun-glassfish-comms-server1.5|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=11;_ThreadName=main;|MQJMSRA_LB1101:
      Looking for Broker Running at:localhost:37676|#]

      [#|2008-12-10T16:07:59.719+0100|WARNING|sun-glassfish-comms-server1.5|javax.jms|_ThreadID=11;_ThreadName=main;_RequestID=d6b40d60-5d19-48a5-a87c-b58efbf24378;|[C4003]:
      Error occurred on connection creation [localhost:37676]. - cause:
      java.net.ConnectException: Connection refused|#]

      As we tested, that port receives connections though....
      Can this be a logical error or a race condition ?

      BR

      Babbis

      1. 1531-fix.jar
        8 kB
        Yamini K B
      2. 1531-fix-2.jar
        8 kB
        Yamini K B
      3. debug-patch-jan22.jar
        11 kB
        Yamini K B
      4. FailStart_17h26m.tgz
        158 kB
        ocorbun
      5. FailStart15h05m.tgz
        290 kB
        ocorbun
      6. NA-server.log
        19 kB
        ocorbun
      7. server2.log
        113 kB
        babbisx
      8. SI-server.log
        42 kB
        ocorbun
      9. SI-server-FINEST.log
        155 kB
        ocorbun

        Activity

        ocorbun added a comment -

        After testing one day on a 20 blades system (plus 2 other smaller systems), we
        can say that the problem is gone with this fix. Thanks!

        Please, explain what this fix does.

        Yamini K B added a comment -

        The hang is due to a synchronization problem in IIopFolbGmsClient code. It is
        holding a lock on currentMembers when adding a member and calls
        notifyObservers() which lands in waiting for thread join to avoid another
        deadlock. At the same time another request thread is calling
        getClusterInstanceInfo() and waiting for the currentMembers lock. The fix is to
        move the notifyObservers() call out of the synchronized block in both
        addMember() and removeMember().

        Yamini K B added a comment -

        Fix checked in on FCS branch:

        Checking in ejb/src/java/com/sun/ejb/ee/iiop/IiopFolbGmsClient.java;
        /cvs/glassfish/appserv-core-ee/ejb/src/java/com/sun/ejb/ee/iiop/IiopFolbGmsClient.java,v
        <-- IiopFolbGmsClient.java
        new revision: 1.2.6.3.2.1; previous revision: 1.2.6.3
        done

        Yamini K B added a comment -

        Fix checked in on truck:

        Checking in ejb/src/java/com/sun/ejb/ee/iiop/IiopFolbGmsClient.java;
        /cvs/glassfish/appserv-core-ee/ejb/src/java/com/sun/ejb/ee/iiop/IiopFolbGmsClient.java,v
        <-- IiopFolbGmsClient.java
        new revision: 1.2.6.4; previous revision: 1.2.6.3
        done

        adrian77 added a comment -

        Fix works.


          People

          • Assignee:
            Yamini K B
            Reporter:
            babbisx
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: