sailfin
  1. sailfin
  2. SAILFIN-1717

Help text for start-instance command is not in correct format

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: doc
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,717

      Description

      Sailfin-b09

      Steps to reproduce:

      • asadmin start-instance --help

      The above command returns the help text in this following format:

      ./asadmin start-instance --help
      <!DOCTYPE REFENTRY PUBLIC "-//Sun Microsystems//DTD DocBook
      V3.0-Based SolBook Subset V2.0//EN" [ <!-ArborText, Inc., 1988
      1999, v.4002--> <!ENTITY metainfo SYSTEM "metainfo.sgm"> <!ENTITY
      options-common SYSTEM "options-common.sgm"> <!ENTITY synopsis-
      common SYSTEM "synopsis-common.sgm"> <!ENTITY % commonents SYSTEM
      "smancommon.ent"> %commonents; <!ENTITY % booktitles SYSTEM
      "booktitles.ent"> %booktitles; <!ENTITY Dash "–"> ]> <?Pub
      UDT _bookmark _target> <?Pub Inc> <refentry id="start-instance-
      1"> <refmeta><refentrytitle>start-
      instance</refentrytitle><manvolnum>1</manvolnum>&metainfo;
      </refmeta> <refnamediv><indexterm><primary sortas="start-
      instance">start-instance — starts a server
      instance</primary></indexterm><indexterm><primary sortas="starts
      a server instance"> starts a server instance — start-
      instance</primary></indexterm><refname> start-
      instance</refname><refpurpose>starts a server
      instance</refpurpose> </refnamediv>
      <refsynopsisdiv><title>&synp-tt;</title>
      <cmdsynopsis><command>start-instance</command>&synopsis-common;
      <arg
      choice="plain"><replaceable>instance_name</replaceable></arg>
      </cmdsynopsis></refsynopsisdiv> <refsect1><title>&desc-
      tt;</title> <para>The <command>start-instance</command> command
      starts an instance with the instance name you specify.</para>
      </refsect1> <refsect1><title>OPTIONS</title> <variablelist
      termlength="medium">&options-common; </variablelist></refsect1>
      <refsect1><title>OPERANDS</title> <variablelist

        Activity

        Yamini K B added a comment -

        Appears to be a GlassFish docs issue. Some of the man pages
        (start/stop-instance, jbi commands) seem to be corrupted.

        chinmayee_srivathsa added a comment -

        I have no idea how this can happen. I handed off GlassFish man pages for SGES
        2.1 and the JAR file containing the correct man pages is at:
        http://swpubs.sfbay/writing/appserver/CommsAS911/glassfish-help-20081218.jar

        Terena staged this JAR file for SGES 2.1 (see email below). The (SailFin or
        GlassFish) build should be picking up this staged JAR file called
        glassfish-help-20081218.jar.

        Reassigning to CLI engineer.

        Thanks, Chinmayee

        -----------------------------------

        Hi Chinmayee,

        I've just staged and integrated this.

        It will go in for the 12/20/2008 PST
        nightly build.

        Terena

        Chinmayee Srivathsa wrote:
        > Hi,
        >
        > Thanks, Harpreet.
        >
        > Terena, issue 6939 against SGES 2.1 man pages is approved and the new JAR
        file is at
        http://swpubs.sfbay/writing/appserver/CommsAS911/glassfish-help-20081218.jar.
        > Please stage the new man pages JAR file and point the properties file to this JAR.
        > Thank you,
        > Chinmayee
        >
        > On 12/19/08 14:56, Harpreet Singh wrote:
        >> Chinmayee - please go ahead and integrate this with Terena's help. I have
        approved the issue.
        >> - Harpreet
        >>
        >> Chinmayee Srivathsa wrote:
        >>> Hi Harpreet,
        >>>
        >>> Yes, I really think this is very important. The user sees garbled output in
        some man pages.
        >>>
        >>> The risk for fixing this bug is low because I will not be checking man pages
        directly into the build.
        >>> Terena needs to stage the new JAR file (on the external site) and she will
        make only one change in a properties file in the build to point to the new JAR file.
        >>> The JAR file with the fixes is at:
        http://swpubs.sfbay/writing/appserver/CommsAS911/glassfish-help-20081218.jar
        >>>
        >>> Thanks,
        >>> Chinmayee
        >>>
        >>> On 12/18/08 18:42, Harpreet Singh wrote:
        >>>> Chinmayee
        >>>> Is this absolutely required? The next build is RC2 for dec 22.
        >>>> - Harpreet
        >>>>
        >>>> Chinmayee Srivathsa wrote:
        >>>>> Hi,
        >>>>>
        >>>>> There is a new bug on one of the SGES 2.1 man pages.
        >>>>>
        >>>>> Is there another promoted build of SGES 2.1 planned? I would like to
        update the man page JAR file.
        >>>>>
        >>>>> Thanks,
        >>>>> Chinmayee
        >>>>>
        >>>>> -------- Original Message --------
        >>>>> Subject: [Issue 6939] [docs] man-page for asadmin recover-transactions
        prints garbage
        >>>>> Date: Wed, 17 Dec 2008 16:46:15 +0000
        >>>>> From: pauldavies@dev.java.net
        >>>>> To: cs194067@dev.java.net
        >>>>>
        >>>>>
        >>>>>
        >>>>> https://glassfish.dev.java.net/issues/show_bug.cgi?id=6939
        >>>>>
        >>>>>
        >>>>>
        >>>>>
        >>>
        >

        prasads added a comment -

        Moving this issue to the started state

        tcfujii added a comment -

        The fix is to integrate glassfish-help-20081218.jar.

        tcfujii added a comment -

        Updated appserv-docs/bootstrap/project.properties in the SAILFIN20_FCS_BRANCH
        for glassfish-help-20081218.jar.


          People

          • Assignee:
            tcfujii
            Reporter:
            dpk
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: