sailfin
  1. sailfin
  2. SAILFIN-1741

NPE on restart of failed instance at JxtaReplicationSender.sendReplicationAdvisoryState(JxtaReplicationSender.java:1004)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Other

      Description

      Parent Issue:1739

      Time Line:
      2009-04-24T16:41:07 - Killed instance110 and its NA process
      2009-04-25T18:31:41 - restarted instance110

      Logs Location:
      /net/asqe-logs.sfbay.sun.com/export1/SailFin/Results/ST/2.0/converged-failure/fail/b11-1failure-1restart/

      NullPointerException noticed in all instance logs after restarting the failed
      instance. Following is the stack trace:

      [#|2009-04-25T18:51:12.788+0530|SEVERE|sun-glassfish-comms-server1.5|javax.enterprise.system.container.sip|_ThreadID=125;_ThreadName=Thread-113;_RequestID=c0aadeb5-cb9c-488a-a739-0557c6c3d163;|"Caught
      an error while executing task."
      java.lang.NullPointerException
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationAdvisoryState(JxtaReplicationSender.java:1004)
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationAdvisoryState(JxtaReplicationSender.java:991)
      at
      org.jvnet.glassfish.comms.replication.sessmgmt.SipApplicationSessionStoreImpl.sendLoadAdvisory(SipApplicationSessionStoreImpl.java:589)
      at
      org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.sendLoadAdvisorySipApplicationSession(SipTransactionPersistentManager.java:4195)
      at
      org.jvnet.glassfish.comms.replication.sessmgmt.HASipApplicationSession.timeout(HASipApplicationSession.java:777)
      at
      com.ericsson.ssa.sip.timer.GeneralTimerImpl.timeout(GeneralTimerImpl.java:189)
      at
      com.ericsson.ssa.sip.timer.GeneralTimerBase.call(GeneralTimerBase.java:72)
      at
      com.ericsson.ssa.container.SipContainerThreadPool$SipContainerThreadPoolThread.run(SipContainerThreadPool.java:295)

      #]

      ***********

      Seems like a regression. We did not see this with build 10.

        Issue Links

          Activity

          varunrupela added a comment -

          added keyword and dependency

          varunrupela added a comment -

          Here is another Stack Trace leading to the same point:

          [#|2009-04-25T18:51:35.608+0530|WARNING|sun-glassfish-comms-server1.5|javax.enterprise.system.container.ssr|_ThreadID=139;_ThreadName=ContainerBackgroundProcessor[StandardEngine[com.sun.appserv].StandardHost[server].StandardContext[/conference]];_RequestID=4e335732-0244-41b2-a465-a6b24c9729e7;|in
          org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager>>processExpiredSipApplicationSessionReplica:
          Unable to process expiration of SipApplicationSession replica with id:
          17,17,conf7005_10369056conference
          java.lang.NullPointerException
          at
          com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationAdvisoryState(JxtaReplicationSender.java:1004)
          at
          com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationAdvisoryState(JxtaReplicationSender.java:991)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipApplicationSessionStoreImpl.sendLoadAdvisory(SipApplicationSessionStoreImpl.java:589)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.sendLoadAdvisorySipApplicationSession(SipTransactionPersistentManager.java:4195)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.processExpiredSipApplicationSessionReplica(SipTransactionPersistentManager.java:3549)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.processExpiredSipApplicationSessionReplicas(SipTransactionPersistentManager.java:3515)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipApplicationSessionStoreImpl.processExpires(SipApplicationSessionStoreImpl.java:674)
          at
          com.ericsson.ssa.sip.PersistentSipSessionManagerBase.backgroundProcess(PersistentSipSessionManagerBase.java:589)
          at
          org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.backgroundProcess(SipTransactionPersistentManager.java:865)
          at
          com.ericsson.ssa.config.ConvergedContextImpl.backgroundProcess(ConvergedContextImpl.java:215)
          at
          org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1838)
          at
          org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1827)
          at java.lang.Thread.run(Thread.java:619)

          #]
          Scott Oaks added a comment -

          This is likely a duplicate of 1731, because the two different code paths call
          the same method to get the bekey, and that method used to return null in some
          cases. But I can't verify that directly myself; I'll avoid marking it as a
          duplicate until we see if it is fixed in build 12.

          varunrupela added a comment -

          I think you meant duplicate of 1713 and not 1731.

          Scott Oaks added a comment -

          Oops...yes, I meant this is a duplicate of 1713.

              • This issue has been marked as a duplicate of 1713 ***

            People

            • Assignee:
              Scott Oaks
              Reporter:
              varunrupela
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: