sailfin
  1. sailfin
  2. SAILFIN-1777

[intermittent] NPE on new home instance after failure when finding session at JxtaReplicationSender.sendReplicationState(JxtaReplicationSender.java:403)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,777

      Description

      Build 13

      An NPE is thrown on some runs of the below scenario.

      Scenario:

        • Test Name: ShortInstanceFailure_testConverged
          Test Driver - ShortInstanceFailure
          Test App - convergedapp
          Deployable - convergedapp.sar
          SIPp Scenario File - uas.xml
          Scenario:

      NPE:
      ********
      [#|2009-05-13T03:54:56.229-0700|SEVERE|sun-glassfish-comms-server1.5|org.apache.coyote.tomcat5.CoyoteAdapter|_ThreadID=166;_ThreadName=httpSSLWorkerThread-38080-1;_RequestID=ab475d06-a99b-4511-a651-80725c5e07ea;|PWC3989:
      An exception or error occurred in the container during the request processing
      java.lang.NullPointerException
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationState(JxtaReplicationSender.java:403)
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.doTransmit(JxtaBackingStoreImpl.java:825)
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.saveSimple(JxtaBackingStoreImpl.java:317)
      at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.save(JxtaBackingStoreImpl.java:263)
      at
      com.sun.enterprise.ee.web.sessmgmt.ReplicationStore.doValveSave(ReplicationStore.java:193)
      at
      com.sun.enterprise.ee.web.sessmgmt.ReplicationStore.valveSave(ReplicationStore.java:144)
      at
      com.sun.enterprise.ee.web.sessmgmt.ReplicationStore.load(ReplicationStore.java:607)
      at
      org.apache.catalina.session.PersistentManagerBase.doSwapIn(PersistentManagerBase.java:1088)
      at
      com.sun.enterprise.ee.web.sessmgmt.ReplicationManagerBase.doSwapIn(ReplicationManagerBase.java:1900)
      at
      org.apache.catalina.session.PersistentManagerBase.swapIn(PersistentManagerBase.java:1054)
      at
      com.sun.enterprise.ee.web.sessmgmt.ReplicationManagerBase.findSession(ReplicationManagerBase.java:3062)
      at
      org.apache.coyote.tomcat5.CoyoteRequest.doGetSession(CoyoteRequest.java:2828)
      at
      org.apache.coyote.tomcat5.CoyoteRequest.getSession(CoyoteRequest.java:2620)
      at
      org.apache.coyote.tomcat5.CoyoteRequestFacade.getSession(CoyoteRequestFacade.java:912)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:217)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1096)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:290)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:871)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
      at
      org.jvnet.glassfish.comms.clb.proxy.portunif.ClbProxyPipeline$PUTask.doTask(ClbProxyPipeline.java:532)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

      #]

      **********

      See the NPE at node-agents/agent2/instance102/server.log_2009-05-13T03-55-27 in
      the attached logs.

        Activity

        varunrupela added a comment -

        Created an attachment (id=1023)
        attached logs

        prasads added a comment -

        Re-Assigning to Mahesh

        Scott Oaks added a comment -

        Same root cause as 1713.

            • This issue has been marked as a duplicate of 1713 ***

          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            varunrupela
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: