Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: sip_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      1,833

      Description

      FOllowing NPE occured(lots of them) during B2BUA system tests . this Exception is logged somuch that
      it might interfere with the test execution. and also
      If this is a real issue then it has to be moved to WARNING or SEVERE.
      [#|2009-06-30T16:24:17.745-0700|INFO|sun-glassfish-comms-
      server2.0|javax.enterprise.system.container.sip|_ThreadID=35;_ThreadName=SipContainer-
      serversWorkerThread-5060-6;|failed during request processing:
      java.lang.StringIndexOutOfBoundsException: String index out of range: 0
      at java.lang.String.charAt(String.java:686)
      at com.ericsson.ssa.sip.dns.TargetResolver.isNumericIp(TargetResolver.java:466)
      at com.ericsson.ssa.sip.dns.TargetResolver.resolveReq3263_4(TargetResolver.java:395)
      at com.ericsson.ssa.sip.dns.TargetResolver.resolveRequest(TargetResolver.java:296)
      at com.ericsson.ssa.sip.dns.ResolverManager.doResolve(ResolverManager.java:251)
      at com.ericsson.ssa.sip.dns.ResolverManager.dispatch(ResolverManager.java:231)
      at com.ericsson.ssa.sip.DialogManager.dispatch(DialogManager.java:808)
      at com.ericsson.ssa.sip.LocalRouteManager.dispatch(LocalRouteManager.java:148)
      at
      com.ericsson.ssa.container.sim.ApplicationDispatcher.dispatchViaStatelessProxy(ApplicationDispatcher.
      java:633)
      at
      com.ericsson.ssa.container.sim.ApplicationDispatcher.invokeServletDispatchers(ApplicationDispatcher.j
      ava:424)
      at com.ericsson.ssa.container.sim.ApplicationDispatcher.dispatch(ApplicationDispatcher.java:174)
      at com.ericsson.ssa.sip.FSM$1.call(FSM.java:141)
      at com.sun.grizzly.util.WorkerThreadImpl.processTask(WorkerThreadImpl.java:325)
      at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:184)

      #]

      [#|2009-06-30T16:24:17.746-0700|INFO|sun-glassfish-comms-
      server2.0|javax.enterprise.system.container.sip|_ThreadID=35;_ThreadName=SipContainer-
      serversWorkerThread-5060-6;|Problem in servlet.
      java.lang.NullPointerException

        Activity

        sviveka added a comment -

        increasing priority to p2

        sviveka added a comment -

        Found the root cause for the exception is uas.inf (argument to the sipp command ) file contained one
        extra ';'
        moving down the priority.

        binod added a comment -

        Changed the log level to WARNING.

        bash-3.2$ cvs -e vi commit
        cvs commit: Examining .
        Checking in ResolverManager.java;
        /cvs/sailfin/sip-stack/src/java/com/ericsson/ssa/sip/dns/ResolverManager.java,v <--
        ResolverManager.java
        new revision: 1.27; previous revision: 1.26
        done


          People

          • Assignee:
            binod
            Reporter:
            sviveka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: