Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,836

      Description

      Sometimes we end up processing stale expat lists – in particular, in this scenario:

      1) FastExpatList pushes out the expat lists
      2) FastExpatList times out, calls postInvoke()
      3) postInvoke() sets up a new hash map to receive results
      4) We fall back to pulling expat list
      5) The delayed pushed expat list is finally received and stored in the new hash map
      6) Much later, we start a new shape change. But the hash map contains old results.

      The hashmap should be cleared in the preinvoke instead.

        Activity

        Scott Oaks added a comment -

        Expat list changes in 1843 address this.

            • This issue has been marked as a duplicate of 1843 ***

          People

          • Assignee:
            Scott Oaks
            Reporter:
            Scott Oaks
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: