sailfin
  1. sailfin
  2. SAILFIN-1858

getAvailableModules skips converged apps

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,858

      Description

      If the user deploys a converged application (WAR+SIP) to SF v2 the JSR-88
      DeploymentManager method getAvailableModules(ModuleType.WAR, targetArray) does
      not return it as part of the list of available modules...

      The TargetModuleID for the app should be part of the return value.

        Activity

        vince kraemer added a comment -

        added Sreeram to the cc list... this issue is based his report of an issue he
        saw in NB when redeploying a SIP app to SF v2 from NetBeans.

        prasads added a comment -

        The module type of the WAR ( HTTP+ SIP) is not ModuleTYpe.WAR .

        It should be
        XModuleType.getModuleType("org.jvnet.glassfish.comms.deployment.backend.SipArchiveDeployer")

        Can you confirm if this issue exists even after this change has been made ?
        Marking it as INVALID till such time, when the issue is confirmed with the other
        module type as well.

        vince kraemer added a comment -

        I don't understand where 'this change' would be made...

        Are you saying change

        dm.getAvailableModules(ModuleType.WAR,...)

        to

        dm.getAvailableModules(XModuleType.getModuleType("org.jvnet.glassfish.comms.deployment.backend.SipArchiveDeployer"),...

        Which api jar has XModuleType?

        vince kraemer added a comment -

        please respond with additional info...

        prasads added a comment -

        appserv-rt.jar has XModuleType.

        This change would have to be made in the code which is trying to call
        getAvailableModules and passes the Module Type as an argument.

        vince kraemer added a comment -

        ok... in other words the guess that I described in https://sailfin.dev.java.net/issues/show_bug.cgi?
        id=1858#desc4 was 'correct'.

        thanks for the clarification


          People

          • Assignee:
            prasads
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: