Issue Details (XML | Word | Printable)

Key: SAILFIN-1892
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: kshitiz_saxena
Reporter: 1xpert
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
sailfin

message output during start-domain is not correct

Created: 05/Aug/09 05:35 PM   Updated: 31/Aug/09 03:01 AM   Resolved: 31/Aug/09 03:01 AM
Component/s: Tools
Affects Version/s: 2.0
Fix Version/s: b30

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: Sun


Issuezilla Id: 1,892
Tags:
Participants: 1xpert, kshitiz_saxena, naman_mehta and prasads


 Description  « Hide

[root@easqelx14 sailfin]# bin/asadmin start-domain
Starting Domain domain1, please wait.
Default Log location is /usr/nga/temp/sailfin/domains/domain1/logs/server.log.

Sidebyside upgrade between glassfish v1 b60g and glassfish v2 b26

After complete installation of glassfish v2 on a different directory other than
glassfish v1 installation. I edited <v2 installation>/config/asenv.conf for
parameters AS_ACC_CONFIG and AS_DEF_DOMAINS_PATH to point to v1 installation.
Then I execute start-domain command. I notice the following message in which it
says "The domain domain1 needs in-inplace upgrade because its...." This is
incorrect message for user because if user already performed a sidebyside
upgrade, user should not have to do in-place upgrade. Message needs correction.

Message output from start-domain:
[root@easqelx14 sailfin]# bin/asadmin start-domain
Starting Domain domain1, please wait.
Default Log location is /usr/nga/temp/sailfin/domains/domain1/logs/server.log
The domain domain1 needs in-place upgrade because its domain.xml has
a System ID http://www.sun.com/software/appserver/dtds/sun-domain_1_4.dtd and
required System ID is http://www.sun.com/software/appserver/dtds/sun-domain_1_5.dtd
Upgrade completed successfully. Starting the domain...
Redirecting output to /usr/nga/temp/sailfin/domains/domain1/logs/server.log
Domain domain1 started.
Domain [domain1] is running [Sun GlassFish Communications Server 2.0 (9.1.2)
(build b26-fcs)] with its configuration and logs at:
[/usr/nga/temp/sailfin/domains].
Adm



naman_mehta added a comment - 05/Aug/09 10:28 PM

I couldn't get your description.

But, if you do either side by side or inplace upgrade back end code remains
same. Basically it upgrade 1.5 domain to 2.0 domain. So obviously it shows same
message in both upgrade.

If it's message format issue then leave it else give me exact steps to reproduce
the same.


1xpert added a comment - 11/Aug/09 11:42 AM

Per Naman's request, this bug will be assign to Kshitiz

Steps to produce:

1. install sailfin v1 build b60g on machine1, start-domain, start-database,
create nodeagent, start nodeagent
2. install sailfin v1 build b60g on machine2, create nodeagent, startnodeagent
3. create cluster on machine1, create 2 instances, start cluster
4. stop all processes on both machines
5. install sailfin v2 build b26 on machine1, machine2 in a directory different
from sailfin v1 installation
6. on machine1, edit <v2 installation>/config/asenv.conf so that parameters
AS_ACC_CONFIG, AS_DEF_DOMAINS_PATH point to sailfin v1 installation
7. execute start-domain (this is when you will see output message to perform
inplace upgrade). The output of start-domain is as followed. The bug in this
message is where it says "The domain domain1 needs in-place upgrade because its
domain.xml has a System ID
http://www.sun.com/software/appserver/dtds/sun-domain_1_4.dtd and
required System ID is http://www.sun.com/software/appserver/dtds/sun-domain_1_5.dtd"

The message should not inform user to perform in-place upgrade to receive 1.5
dtd version because it does not make sense for user to perform inplace upgrade
after users already performed sidebyside upgrade. Also, user might copy the
entire domain1 directory from v2 to v1 installation and I am not sure if that
will cause problems. The message should give exact statement of what to do to
update dtd version.

Starting Domain domain1, please wait.
Default Log location is /usr/nga/temp/sailfin/domains/domain1/logs/server.log
The domain domain1 needs in-place upgrade because its domain.xml has
a System ID http://www.sun.com/software/appserver/dtds/sun-domain_1_4.dtd and
required System ID is http://www.sun.com/software/appserver/dtds/sun-domain_1_5.dtd
Upgrade completed successfully. Starting the domain...
Redirecting output to /usr/nga/temp/sailfin/domains/domain1/logs/server.log
Domain domain1 started.
Domain [domain1] is running [Sun GlassFish Communications Server 2.0 (9.1.2)
(build b26-fcs)] with its configuration and logs at:
[/usr/nga/temp/sailfin/domains].


kshitiz_saxena added a comment - 19/Aug/09 05:13 AM

Assigning it to myself.


kshitiz_saxena added a comment - 24/Aug/09 03:38 AM

Modified in-place upgrade message as it can be side-by-side upgrade as well.

Checkin logs:
Checking in
./admin-cli/commands/src/java/com/sun/enterprise/cli/commands/LocalStrings.properties;
/cvs/glassfish/admin-cli/commands/src/java/com/sun/enterprise/cli/commands/LocalStrings.properties,v
<-- LocalStrings.properties
new revision: 1.68.2.5; previous revision: 1.68.2.4
done


1xpert added a comment - 25/Aug/09 03:18 PM

hi Kshitiz,

I verify the bug with build sailfin-installer-v2-b30-nightly-25_aug_2009.jar
I notice the message is changed to say domain.xml will be upgraded inline. How
do I do this ? Is there a way to avoid this manual step ?

bash-3.00# bin/asadmin start-domain domain1
Starting Domain domain1, please wait.
Default Log location is /export/home/sailfin/domains/domain1/logs/server.log.
The domain domain1 requires upgrade as domain.xml DTD version does not match the
latest version. The domain.xml will be upgraded inline
from System ID http://www.sun.com/software/appserver/dtds/sun-domain_1_4.dtd to
required System ID http://www.sun.com/software/appserver/dtds/sun-domain_1_5.dtd
Upgrade completed successfully. Starting the domain...
Redirecting output to /export/home/sailfin/domains/domain1/logs/server.log
Domain domain1 started.
Dom


prasads added a comment - 31/Aug/09 03:01 AM

The inline upgrade is automatic, and the user does not have to do any additional
steps. Note that the inline upgrade is only for the domain.xml