sailfin
  1. sailfin
  2. SAILFIN-1969

Failed to look up for failover instance on PUBLISH

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: b31
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,969

      Description

      PUBLISH initial requestes being timeouted (ie no response generated from
      server), null key provided for look up failover server instance.

      Build :
      Sun GlassFish Communications Server 2.0 (9.1.2) (build b23-fcs)

      From server instance server.log :

      java.lang.IllegalArgumentException: Null key provided to lookup failover
      server instance at
      org.jvnet.glassfish.comms.clb.core.sip.DataCentricUtilImpl.getFailoverServerIns
      tance(DataCentricUtilImpl.java:237) at
      com.ericsson.ssa.sip.SipApplicationSessionUtil.getFailoverServerInstanceForBeKe
      y(SipApplicationSessionUtil.java:108) at
      org.jvnet.glassfish.comms.replication.sessmgmt.ExtendedReplicationUtil.getFailo
      verServerInstanceForBeKey(ExtendedReplicationUtil.java:121) at
      com.sun.enterprise.ee.web.sessmgmt.JxtaReplicationSender.sendReplicationState
      (JxtaReplicationSender.java:394) at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.doTransmit
      (JxtaBackingStoreImpl.java:841) at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.saveSimple
      (JxtaBackingStoreImpl.java:338) at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.save
      (JxtaBackingStoreImpl.java:279) at
      com.sun.enterprise.ee.web.sessmgmt.JxtaBackingStoreImpl.save
      (JxtaBackingStoreImpl.java:71) at
      org.jvnet.glassfish.comms.replication.sessmgmt.SipApplicationSessionStoreImpl.d
      oSave(SipApplicationSessionStoreImpl.java:529) at
      org.jvnet.glassfish.comms.replication.sessmgmt.SipApplicationSessionStoreImpl.s
      ave(SipApplicationSessionStoreImpl.java:487) at
      org.jvnet.glassfish.comms.replication.sessmgmt.SipTransactionPersistentManager.
      saveSipApplicationSession(SipTransactionPersistentManager.java:4261) at
      org.jvnet.glassfish.comms.replication.sessmgmt.HASipApplicationSession.save
      (HASipApplicationSession.java:687) at
      com.ericsson.ssa.sip.persistence.ReplicationUnitOfWork.save
      (ReplicationUnitOfWork.java:119) at
      com.ericsson.ssa.sip.persistence.ReplicationUnitOfWork.saveAndUnlock
      (ReplicationUnitOfWork.java:158) at
      com.ericsson.ssa.sip.dialog.DialogLifeCycle.handleFinish
      (DialogLifeCycle.java:311) at
      com.ericsson.ssa.sip.dialog.DialogLifeCycle.onTransactionRemoved
      (DialogLifeCycle.java:179) at
      com.ericsson.ssa.sip.transaction.TransactionManager.removeTransactionFromDialog
      (TransactionManager.java:617) at
      com.ericsson.ssa.sip.transaction.TransactionManager.removeServerTransaction
      (TransactionManager.java:661) at
      com.ericsson.ssa.sip.transaction.TransactionManager.remove
      (TransactionManager.java:631) at
      com.ericsson.ssa.sip.transaction.ServerTransaction.terminate
      (ServerTransaction.java:73) at
      com.ericsson.ssa.sip.transaction.NonInviteServerTransaction.toCompleted
      (NonInviteServerTransaction.java:225) at
      com.ericsson.ssa.sip.transaction.NonInviteServerTransaction.dispatch
      (NonInviteServerTransaction.java:117) at
      com.ericsson.ssa.sip.persistence.ReplicationManager.dispatch
      (ReplicationManager.java:210) at
      com.ericsson.ssa.sip.dns.ResolverManager.dispatch(ResolverManager.java:349) at
      com.ericsson.ssa.sip.DialogManager.dispatch(DialogManager.java:846) at
      com.ericsson.ssa.sip.FSM$2.call(FSM.java:173) at
      com.sun.grizzly.util.WorkerThreadImpl.processTask(WorkerThreadImpl.java:325)
      at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:184)

        Activity

        Mahesh Kannan added a comment -

        b23 is really old. could you please try with b31?

        tatyanalav added a comment -

        ok,thanks, will get a b31 in coming days and will respond with the results.

        Mahesh Kannan added a comment -

        Can the submitter of the bug confirm that this is not seen with the latest build?

        tatyanalav added a comment -

        Trying with b31.Will post the results shortly.

        tatyanalav added a comment -

        Retried with Sun GlassFish Communications Server 2.0 ((v2.1 Patch06)(9.1_02
        Patch12)) (build b31-fcs).
        The issue is fixed. Thanks.

        shreedhar_ganapathy added a comment -

        Marking as resolved since the issue is resolved with latest builds since b31.


          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            tatyanalav
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: